GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Reopen last closed listers


#1

Hi everyone,

I recently upgraded to Windows 7 and since doing so it appears that my default lister is always opened even though the option 'Startup' is set to 'Open the Listers that were open when the program was last closed' is checked.

Is anyone else seeing this?

Thanks,

Dan


#2

If you exit Opus and then run it again via the Start Menu, do you get a default lister again or do you get whatever listers you had when you exited? If you get the right thing, do you then get that every time you reboot? (The problem may be that Opus is unable to save the window state at exit, or during shutdown.)

Is it definitely the default lister you are seeing? Sometimes other programs, or their installers, trigger folders to be launched at startup. Try turning off Explorer Replacement mode and rebooting to see if you then get some Explorer windows opening at startup. If so, the cause of those windows is external to Opus.


#3

He Leo,

It does not matter how I re-open DO or if it is after a reboot. Even if I open up a Windows folder. When I next re-open DO it is my default lister. I am sure it's my default lister as I have multiple tabs in dual view and they are always exactly the same. This isn't really THAT big a deal for me but it is not what I am used to seeing DO do.

Sorry about the delay in response, I didn't see anything come in for a while and then with the holidays yadda yadda :slight_smile:

Thanks!


#4

If you type /dopuslocaldata\State Data into the location field in Opus it should take you to a settings directory.

Open that same directory in Explorer, arrange some Opus windows in a way you'll recognise, then exit Opus via the tray icon.

In the Explorer window you should see that openlisters.oll gets updated. You can open it in a text editor to confirm that it saved the right sort of thing (look for the directory paths you had open as a good indicator).

If that part is working but restarting Opus gets you something else then we can look at that next...


#5

And hello again Leo :slight_smile:

So I did as you asked and came up with some rather interesting (pronounced 'confusing') results.

When I close the lister as instructed it saves the file correctly. If I simply alt-f4 or X out it does not.

If I then open a new lister through the start menu it opens up correctly (the previously open lister is re-opened). If I simply double-click on the desktop it opens my default lister and rewrites the openlisters.oll file to reflect this.

I certainly hope that helps you because it doesn't make much sense to me o.O

Thanks!


#6

I think that's normal. Double-click on the desktop doesn't have the option to re-open the previous listers. That option is only there in the Startup section of preferences which covers running Opus on its own (i.e. dopus.exe or a shortcut to it).


#7

Hi Leo,

My XP installs have always opened the previously closed listers I guess they are the bugged ones then :smiley:

Thanks for the help!


#8

Where are these XP installs? Are any of them still available that behave this way? If so, it'd help to compare the Opus configs from one of them to the current Win7 system Opus config... look for a difference that could explain the behavior.

Did you perhaps used to have the Update Default Lister automatically when closing a Lister option enabled, and then have all of the Launching Opus options set to Open the Default Lister???


#9

I have the same problem on my Win 7 install (x64 ultimate ver). Vista x64 used to remember at least configured tabs while Win 7 seems not to.
Though when I saved the listers config and changes the startup setting to open not the last opened but a particular saved one, it works.

Nevertheless, I haven't managed to made DO open tabs that were active when last closing it....


#10

How are you starting Opus and/or opening your Opus windows?


#11

Just the shortcut in quicklaunch
"C:\Program Files\GPSoftware\Directory Opus\dopus.exe"


#12

What happens if you completely exit Opus and then run that shortcut?

Which settings do you have under Launching Opus -> Startup?


#13

Now I have checked load the saved configuration as it brings back my favorite tabs. But earlier I had bring the last opened tabs and it didn't worked :frowning:


#14

Can you try changing it back to what wasn't working and then exit Opus and restart it with the shortcut?

The reason I ask is to check that the right thing is happening when Opus is exited when the OS isn't shutting down, and started in the way you expect it's being started, to see if that works. If it doesn't work then it's a configuration issue somewhere; if it does work then we need to work out what is either preventing the settings being saved during OS shutdown, or how Opus is really being started (something else may be launching it at startup, e.g. by launching a folder shortcut earlier in the boot process).