Replace Explorer for all folders doesn't

This is a continuation of a reply I submitted to a very old thread yesterday. Leo asked:

Which folders have are you double-clicking? What happens instead? Does Explorer open, or nothing, or something else?

First, I'm not running DOpus as administrator, only as a simple user account. And second, what happens is that Windows Explorer keeps opening. I'd like to be able to use the folder shortcuts on my desktop to open DOpus instead, but Windows Explorer keeps opening. Any ideas?

  • Can you post a screenshot of your Preferences / Launching Opus / Explorer Replacement page?

  • If you select one of the options there, then click OK, and then use File > Exit Directory Opus, then re-launch Opus and re-open Preferences, is your choice still selected?

  • If you right-click a folder on the Windows desktop, is there an option to Open in Directory Opus? If so, does it work, or does that also open File Explorer?

Here's the requested screenshot:

In answer to your questions, yes, my preferences on that page are "sticky" in the sense you describe from exiting to restarting DOpus. And when I put a folder or a folder shortcut on the Windows desktop, I do get the "Open in Directory Opus" option, and it does indeed open in DOpus when I use it.

In Opus, please go to Settings > File Types, and then File > Diagonstic, choose the Folders option and attach the results:

image

Done. The longer I use DOpus, the more of these tricky little diagnostic things I learn!

Opus_FTD_Folders.zip (70.8 KB)

Thanks!

I can't see anything wrong in there.

  • Could you do the same diagnostic for the .LNK file type? Maybe the problem is with shortcuts rather than Explorer Replacement in general.

  • What are the shortcuts pointing to? We found an issue with shortcuts to Libraries, but it would not affect shortcuts to normal folders.

I think I may have figured out my problem. I learned that there is apparently a different between a shortcut sitting on my desktop and a shortcut sitting in a "fence" on my desktop courtesy of Stardock's Fences application. Since disabling Fences and removing it from the picture, folder shortcuts on my desktop open in DOpus just fine. As soon as I re-enable Fences and double click the same folder shortcut in one of its containers, it opens in Explorer. I'm guessing they don't respect the proper handler. I'm going to take it up with Stardock.

FWIW, I noticed Fences in your file type details and figured it might be involved in how desktop shortcuts are handled. I installed it earlier, but I didn't see any issues, at least with the default configuration.

Just tried with it again and it seems OK with everything I can think to test:

  • Folders on the desktop
  • Shortcuts to folders on the desktop
  • Folders inside a fence
  • Shortcuts to folders inside a fence

All of those open in Opus OK for me.

That was with Opus 12.22 and Fences 3.0.9.11.

Seriously?! Because the moment I put a shortcut or a folder into a fence on the desktop, it opens in Windows Explorer. Now to be fair, I've been adding my fences as what they call "Folder Portals". Did you try those? Now I'm going to go try a regular fence.

Aha! The folder portal is their problem! They must be doing something funky there. Thanks for testing that out and letting me know. That's really above and beyond the call, but I'm going to update Stardock with what I've just learned. If you're up for it, you might try creating a folder portal instead and see if there's any way for you to get it to work in one of those.

When I tried folder portals earlier, double-clicking a sub-folder opened it within the portal itself, I think. Maybe there's an option somewhere in Fences that controls what happens? (I looks like a cool tool, but I'm not very familiar with it.)

I probably didn't try an actual shortcut inside a folder portal, either; only sub-folders in portals, and shortcuts in basic fences.

Interestingly enough, what I'm seeing is incredibly schizophrenic. If I create a folder or a folder shortcut in a folder portal, double-clicking them opens them in Windows Explorer. If, however, I double-click empty space in the folder portal, or the title bar, which is the shortcut to open the underlying folder for the portal, then that opens in Directory Opus! Why oh why didn't I take the blue pill?!?!