Restoring Backup on another Computer does not port some icons or scripts

I have customised toolbars and several scripts that work as I want. I have backed up choosing all the options. When I restore the backup onto another computer, I find that some of icons on my toolbars are not restored, and some scripts are not overwritten on the new computer. I notice that sometime there is more than one script selected as well.

Are the icons backed up? I have installed several sets from the forum.

Are all the scripts backed up? Does restoring replace existing scripts? If I make a change in the script on the first computer, it does not seem to transfer to the second computer.

I have both computers configured with the same folder structure on a single C Drive.

I have read through the extensive notes on this Forum but may be missing a vital step.

Where are the missed icons and scripts stored? (As in the directory path.)

I used this dialogue to import them.

C:\Users\renal\AppData\Roaming\GPSoftware\Directory Opus\Script AddIns

Also, the standard from the install.

Any installed Icon Sets should be backed up, at least assuming all the options here were on:

(Edit: Same for things in the Script AddIns folder.)

The .ocb backups are really .zip archives, so you can rename them and look inside to see exactly what was included. The icon sets would normally be .dis files within the Icons sub-dir.

Yes, that was my understanding. I will have a look later and report back.

So, I was expecting that a change to a script that works on computer 1, would save into the backup, and then overwrite the same script on computer 2.

When I imported the icon set, my tool bars updated to the new icon, except for a couple of buttons. I changed these and saved the toolbars, and even made a toolbar set. I backed up with same settings you posted, and imported all except for the "replace" option on the import. Is that where I am going wrong?

The "Replace entire config" option, when importing the backup, will overwrite everything as well as remove any config files that no longer exist in the backup.

That's what I usually use myself. I'd have to look at the code to see if it's required here. Will try to tomorrow.

From my quick test, it worked correctly with a script file:

Thank for following this up, Leo.

I also can get the backup and restore to work as you have demonstrated. I think I will get in the habit of replacing everything when I restore backup configurations. I think my problems with the scripts relate to the scripts that interact with the "Everything" indexing. Later, I will investigate this more thoroughly, but I think the trick is the settings or to force a re-index to pick up folders (I have this script displaying folder sizes as well file sizes).

However, I remain unclear about the icons. I download the "dis" files into my download directory, then import them into DOPUS via the dialogue window accessed through preferences. I move the new set to above the standard DOPUS icon set. My toolbar icons are correctly showing. Then I backup the configuration files and restore them on a second computer. The icon "dis" file is not imported on the second computer. There is no record of the icon set in the appropriate dialogue.

Make sure your are selecting all the categories when doing the backup and restore.

Icon sets in backups seem to work here:

All is now clear! Users need to put the icon sets into the "/iconsets" directory and then import them, into the icon manager, in preferences. When the user does this and performs a backup, the icon sets and the settings are copied to the backup. Restoring the backup and selecting all options ensures that the new computer matches the old computer.

@Leo Is this by design? Is there a way to copy the imported icon sets automatically into the default icon set folder?

You don’t need to do that.

Importing them via Preferences will copy them into /iconsets automatically.

The video shows the /iconsets folder only as a second confirmation of what’s happening when sets are added or removed in Preferences or via restoring a backup. The folder isn’t directly modified at any point in the video.

I wasn't dragging the dis file into the bottom window. Instead, I was importing them with the button at the top of the dialogue. If I had 6 dis files in the dialogue box and then backed up, the resultant icon dialogue (after restore) only had 2 sets showing. I am not sure what was going on, but when I manually placed them in the icon directory and imported them, the problem went away and my toolbars had the correct icons.

I did it your way dragging the dis file into the bottom pane and it worked as expected. It could be an issue with that import button. Now, my backup and restore are working as expected.

As I have used a backed-up configuration for years (probably back to vs 11), my configuration could have been corrupted in some way.