GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Right Click Causes DOPUS Freeze

Running V10.0.2.0 64-bit DOpus in Win 7 Pro. When I right-click on a file I get the rotating disk. Sometimes awhile later 10-30 sec the right-click menu appears, but not always. If more than one file is selected then it seems to take forever, and I usually open task manager to abort the program. At first I thought this only was a problem with JPG files, but it seems that it happens across the board regardless of file type. It also occurred withthe 10.0.0 Version and I hped the update wuld cure the problem, but it has not. Any ideas? V9 had no such problem. Searched the forum but found no reference to this issue.

Have you checked out Crash, exit or high CPU when right-clicking certain files in the FAQ?

Regards, AB

probably one of the context menu items is having a problem executing ... try disabling them temporarily or putting them into the "shift - rightclick" menu to see if that solves the problem.

the SEND TO item is frequently a problem or maybe a recently installed software with a context menu entry.

I checked out the FAQ as recommended. Invoking the "Hide Windows Items on File Context menu" prevents DOPUS from crashing as the FAQ suggests. I ran the Debugger and ShellEXView to try to track down the culprit. On the first go round the program halted at a Mozy context item that I disabled with Shell EX. However the problem did not go away. The last item in Debug is now a DOPUS item:
[3008] [7572] dopus: (MBAMShlExt Class). Not sure what this means..any additional suggestions?

MBAMShlExt Class seems to be part of Malwarebytes' Anti-Malware. Try disabling its context menu integration (or uninstall it completely).

I could not find Malwarebytes on the machine. However I deleted a slew of small programs I had installed over the years since 2009. Among them was 7-zip (x64) and Filezilla although there were others too. Can't be positive which it was. However ShellEx was little help FYI. I disabled every program listed that was not by Microsoft and the program persisted. Debug seemed to simply stop at a different place but the problem remained. A wholesale deletion of these small utlity programs aquired overtime seemed to do the trick, but I know this is of little help to those having the same issue.

Anyway, the problem is gone. What a pain...

well, SHELLEXVIEW only display those items setup by a DLL extension file. There are other context menu items associate with EXE commands that can be displayed with shell menu view...SHMNVIEW

I would guess either might cause a hang but I don't know.

I've had a similar (but not identical) problem since I went from Win7 SP1 x86 to Win7 SP1 x64 (and DOpus 10.0.2.0.4269 x86 to x64) : Very frequently when I right clicked on one (or multiple) files, DOpus didn't freeze, but crashed with a "Directory Opus has stopped working" (AppCrash). popup.

I did read the the suggestions here about incorrect program entries in the context menu, but was far from convinced because (1) this was a fresh Windows install on a new laptop, and (2) I never had this problem with Win7 x86 and DOpus x86 (on my old laptop or desktop), so I think this is definitely 64bit Windows 7 or 64bit DOpus related.

However I did find a solution (or rather circumvention), don't know why I tried this, but it did work: I'm now running DOpus in Vista SP2 compatibility mode, and have not had a crash since (a couple of days).

Ron

You really do not want to run Opus in compatibility mode. It'll mess up the way it does Explorer Replacement, the way it handles Libraries, and more.

Even a fresh Windows install has lots of shell extensions, and no Windows install is truly fresh (unless you haven't even installed any drivers or other utilities, which seems incredibly unlikely).

The FAQ explains how to investigate the problem and is the best way to do it. Why not do that instead of trying random other things? :slight_smile:

Well, apparently "Qualcomm Atheros Bluetooth Suite" seems to be the culprit. After adding CLSID {B8952421-0E55-400B-94A6-FA858FC0A39F} to the ignore_context_menus list I've had no further crashes.

Thanks,
Ron

Me too Right Click Causes DOPUS Freeze about 30 second.
Not always but sometime. It made me almost quit using Dopus.

I use Dopus almost 1 year without any problem. And love it very much.
But the problem occur recently.

But my problem solve just now. By follow the FAQ above. My problem is about "Send To Shortcuts".
I have disable it by using ShellExView and disable context menu "Microsoft SendTo Service"

===================
Send To Shortcuts:

If your context menus work but take a long time to open, it may be because of something in your Send To sub-menu. For example, shortcuts pointing to unavailable network paths may cause a 30 second delay on the menu opening.

As of Opus 10.0.3.2, the Sent To sub-menu is only built when you actually open it, not when its parent menu opens, so this should be less of a problem and it should be easier to tell where the problem is.

If you think there is a problem with your Send To menu, try right-clicking the same files/folders in Windows Explorer and see if opening the Send To sub-menu there triggers the same problem.

Thanks