GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Right-click crash

DO crashes less than a minute minute after use. It will crash immediately if you right-click on a file. Un-installed, re-installed, still the same.

The error (0xC0000005) occurred in thread 'dopus_lister' at address 0x00007ff74f2b6779.

Sent dumps to crashdumps@gpsoft.com.au

Just updated to 12.15 and DO has become unusable. Clicks on anything does not work, then it crashes. I have to kill it in the task manger. error (0xC0000005). I would like to revert back to 12.14. I do not have time this morning to investigate what's going on. Can you supply a link to 12.14?

Old installer:

Please also zip and email any crash dumps that were created so we can look at what's happening:

(I merged this with the related thread, but the forum put the posts in a strange order. The previous two posts are from the older thread. This is a reply to the root post at the top.)


Does it matter which type of file you right-click, or which folder you are in? e.g. Try with a .txt file in C:\ to rule out those things.

Is the crash happening when the menu opens, or only when you select something in the menu? From the crash dump it looks like the menu has closed, but it's possible it closed itself or failed to open. On the other hand, if it happens when selecting an item, does it matter which item it is?

The crash dumps indicate the file display is being closed (or changing folders) while the context menu is open, which should not happen normally.

It could be a bug in Opus, maybe triggered by having something custom in the menus; are you using a customized right-click menu or is it just the defaults?

It could also be triggered by a third-party shell extension doing something it shouldn't when Opus asks it to add its items to the right-click menu. A quick way to test that is to turn on Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus and see if the problem still happens. If that stops the crash, I can give details on how to track down which component was causing it.

We don't have any similar reports, so whatever is happening is likely to be triggered by either something unique in the Opus configuration or an interaction with something else installed on the same machine.

Very random. everything works sometimes, but after a minute or two locks up. At the moment if I hover over a tab or folder in the tree, its hi-lights, but won't open the folder. Every time I exit it gives me the program error encountered. Not sure what do do at this point. I've already uninstalled and re-installed and it still crashes before any modifications

Did things work again when you went back to 12.14, or was that the same?

Same, but everything was good until I upgraded.

Updating Opus was just a coincidence in that case. Do you know what else changed or updated on the system around the same time?

Have you tried the Preferences option I mentioned above?

This seems to work. Been using it for 5 minutes no crashes / error messages.

If it's still working well, that definitely means the problems are being caused by a third party shell extension.

From the crash dumps, it looks like the crash happens a while after the extension is called, so it is probably corrupting memory and causing something to go wrong at a random (usually short) time after it is called. That makes it a bit harder to track down.

If you want to track it down, the best thing to do in this case is:

  • Download ShellExView, via the Download ShellExView for x64 link near the bottom of the page.

  • Run ShellExView and click at the top of the list to sort by the Type column.

  • The extensions with type = Context Menu are the ones we're interested in. Select half of them, right-click, and Disable Selected Items.

  • Back in Opus, turn off Hide Windows items on file context menus so it's back to normal.

  • See if the problem comes back.

    • If it does come back, you know the problem extension is in the half that hasn't been disabled yet. Try disabling some more until the problem stops happening.

    • If it does not come back, you know the problem extension is in the half that has been disabled. Try re-enabling a few at a time until the problem comes back.

  • With that process you can narrow it down to a particular component that is causing the problem.

If you find the component, what to do then depends a bit on what it is. Let us know what you find. It may be worth reporting to the component's authors, or looking for an update of the related software. We may also be able to install the same thing and see if we can reproduce the problem and, if so, add a workaround into Opus.

Thanks.

Hi Leo. I had the same type of issue: immediate crash when right click on drive, both in foldertree and in drve toolbar. Dopus Pro v12, build 7263 on Win10_X64. Your suggestion worked (disable Windows Items under Win Integration). Could you please give the promised details how to identify the culprit? Thanks in advance/

Sorry, I missed your reply june 27 which was posted below the text. Assume this is still the way to go?

Recent crashes right-clicking drives have been caused by the shell extension installed by Alcohol. If you have that installed, try disabling its shell extension and it should fix the problem. Otherwise, the steps above should find the cause.

Disabling the Alcohol shell extension appears to correct my freezing problems. I couldn't even access Preference or any other menu items. Thanks for the help.

Same here!
Have the guys at alcohol been made aware of this?