GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Right-click does nothing in file list

Using Directory Opus 11.15 x64.

When I right-click on a file list item, nothing happens. The program does not crash, or show any other message. It just does nothing.

I do not have Admin access on my workstation, but I don't think that is the entire problem because when I right-click on the same file in Windows Explorer, I get the normal context menu.

Bob

Do you see this in all folders, including under, say, My Documents, or only in some?

Opus won't show a menu for files that cannot be accessed (opened with read permission). (Explorer will show a menu, but almost nothing in the menu will work.)

If it happens everywhere, please try turning on Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus (shift overrides) to see if that helps.

If that helps, the Finding the culprit section here has the steps needed to track down the shell extension causing the problem.

It occurs for all folders and all file types.

I had already tried "Hide Windows items on the file context menus" (sorry, I should have stated that in my first message), and that had no effect. With the latest version of DebugView, I see various results, but never a CLSID. For example, the first time I ran it, I saw "[4004] CLimitsController::UpdateLimits" messages appear once per minute, followed by similar entries.

I have attached the DebugView log.
debugview.txt (698 Bytes)

What view mode are you in? If you've accidentally switched to Power mode, it's possible the right button has been configured to have no effect.

View mode is Details. And I have no idea how to switch in and out of Power Mode (didn't even know it existed). The Help file defines Power Mode settings, but not how to turn Power Mode on and off. In Preferences/File Display Modes/Power Mode Buttons, Right Button is set to "Context menu (select)".

Right-click in the file display works when the view is Thumbnails, but not when it is Details or Details + Thumbnails.

Are you right-clicking on the file names themselves? (Not anywhere else on the line.)

Any tools installed that change mouse behaviour? Or anything like AutoHotkey scripts running?

Yes, I am right-clicking on the file name itself. I have the LogiTech G700S mouse driver installed (version 8.58.183 of the Logitech Gaming Software; the newer version did not work for me, so I reverted to the prior version), but that has no settings changed for the right mouse key. And when I completely unload that driver and restart Directory Opus, including terminating dopusrt.exe, the right-click behavior is the same.

This behavior is relatively new. On the 17th, NodeJS, an UltraEdit update, and a TortoiseSVN update were installed, but right-click worked fine for a few days after that. No other software changes were made. OS patches were done last night, but the right-click problem started before that.

I have not changed any tools running.

It certainly seems odd, with it working in Thumbnails but not Details.

[ul][li]It might be worth a try to see if it happens with the default config. If you want to try that:

[ul][li]First, create a backup of your exiting config, using Settings > Backup & Restore. Store it on your Desktop or in My Documents.

[/li]
[li]Then, uninstall Opus, and reboot when prompted.

[/li]
[li]Reinstall Opus (installer link if needed).[/li][/ul]
See if things work OK, and when done testing you can use Settings > Backup & Restore to restore the config backup and be back to normal.


[/li]
[li]Another thing to check: While in Details mode, do the menus off the main toolbar work OK, including ones that overlap with the file display?

e.g. If you click on the Tools or Settings menu, and they overlay with the list of files, can you see the whole menu?

What about if you right-click the empty space on a toolbar; does that menu appear OK while in Details mode?[/li][/ul]

Since we no longer have local admin access to our machines, it took a while to get Internal Support to get around to it. I asked them to put 11.16 on the machine, but I still see 11.15, but right-click now works again. And I still have no idea what went wrong. I know a reboot, by itself, wasn't the answer because that had already been tried.

To answer your questions:
-- Yes, the menus off the main toolbar were still working, including the ones that overlap the file display;
-- Right-clicking empty space on a toolbar showed a menu.