GP SoftwareTwitter
Opus FAQsManualCommandsObjects

RTF-Viewer (and Editor) (32-bit only)

I know, how to do my work :exclamation:
Ever seen a bugfree application? :wink:

The best of it is: I am able to reproduce it.
Fixing the second (switching between rtf and another filetype) will be hard. I have to think about it a while.

Please stand by.

Unicode filename support and 64 bit. :wink:

Regards, Norbert

This is a Delphi plugin so that may be difficult for Dinkelhopper to do for now. 64-bit at least; I don't know what the state of Unicode support is like.

CodeGear, who now own Delphi and most of what was Borland's development tools, have 64-bit support on the 2009 roadmap according to Wikipedia (though the roadmap article they cite does not seem to be online anymore).

I've been thinking about trying to write a generic 64-bit proxy for 32-bit plugins, like I wrote to allow 32-bit ActiveX controls (e.g. Adobe Reader and Adobe Flash) to work within the viewer of 64-bit Opus. It should be possible... 101 other things to do as always, though.

@leo
Thanks for your explanation :slight_smile:

New Release post #1
(Bugfix and one new feature)

@Ross
I hope, we're stable now :wink:

Update: A workaround for this problem is included in Directory Opus 9.1.1.8 which just came out.

Please see Heads-up: dopus_fileinfo crashes and solution if you're using this plugin and have found Opus crashes sometimes.

Hopefully it'll be easy to fix but I figure the mysterious crash may be causing problems for some people so it's worth giving everyone a heads-up on how to avoid it for now.

Very good plugin, it even can edit. Thank you!

A workaround for the dopus_fileinfo crashes has been included in Opus 9.1.1.8. If you use this plugin then you should update Opus to avoid the crashes.

Is there a way that a hotkey can be assigned to switch the keyboard entry focus back and forth between the lister and the ViewPane editor? I know of the command "Set VIEWPANE=Toggle". But this only toggles display of the viewer pane and does not shift the focus. Also - I don't think Dopus hotkeys work when inside of the RTFViewer?

My goal is to be able to move between editing different files without any use of the mouse.

You could just use the tab key?

Opus hotkey assignments (that are not system-wide) will not work when any of the following have the system focus:

  • Any of the three Utility Panels
  • The Viewer Pane
  • Fields on toolbars

Opus hotkey assignments (that are not system-wide) will work if any of the following has the system focus:
  • The folder Tree
  • A File Display

You can create a workaround to set focus from the Internal Viewer back to the Source file display by doing the following:

  1. Right-click any Opus toolbar and select Customize.
  2. From the Customize dialog select the Keys tab.
  3. Create a new hotkey.
  4. Ensure the System-wide Hotkey option is enabled.
  5. IMPORTANT: You must choose a unique hotkey that is not used by any software package, including Windows. So key sequences such as: spacebar and tab, even when combined with qualifier keys (Alt, Shift, Ctrl) are not viable options, since most combinations have a meaning in Windows itself or in other Windows programs. For this particular function, I personally use Win + Shift + O.
  6. Specify this function:
    Go LASTACTIVELISTER
    Set FOCUS=Source
  7. Set Name and Tip values to personal preferences.
  8. Save the hotkey and exit Customize.
Now, whenever you tab into the Internal Viewer pane, you can always get back by pressing Win + Shift + O. The same hotkey above should also work to set focus to Opus from any other Windows program as well.

Thanks kenalcock. That solved half the problem to go from ViewerPane --> Lister. (but not vice-versa).

I found this solution to go both ways with AutoHotKey:

#IfWinActive, ahk_class dopus.lister
F1::ControlFocus, dopus.filedisplay1, ahk_class dopus.lister
F2::ControlFocus, TRichEditHack1, ahk_class dopus.lister
#IfWinActive

When your are in a Lister with the Internal Viewer open, you can just Tab into the Viewer pane.

Had to reinstall Windows - Win XPSP3 on an HP dualcore Pavilion - and everything is working in DOpus except RTF viewer:( - it shows 'loading' for a nanosecond then just a blank pane. The debug.txt option doesn't work either; I cut and pasted the filename from the readme, honest. If I disable it I see raw RTF files. What's gone wrong? (deleted the plugins, redownloaded, etc.)

Hi,

Is it really \GPSoftware\Directory Opus\Viewers\dopus_viewer_debugfile.txt?

Can you reproduce this issue with every RichText-File?

Hi DH

Yes, it's the same for any RTF, however generated - all other file formats (vid/aud/txt/gfx) work. I haven't reinstalled Office yet...? Also haven't done a scorched earth reinstall yet.

Thanks

SOLVED! - Installed Office 2003 and it works!

Hmm, but that's not the whole purpose.
It should work without Office installed.

I'll have a look at this next week.

Thanks - it did strike me as strange. Maybe it's a Visual Basic thing.

Just to clarify - I have Program Files (but not Application Data) on drive D, so when I reinstalled XP to drive C, I reinstalled DOpus to [i]D:\Program Files\GPSoftware\Directory Opus[/i], overwriting the original folder but creating a new [i]C:\User Name\Documents and Settings\GP Software[/i] folder.

I have done it before, months back - but can't remember if I had a problem with RTF Viewer last time:(

The only thing I did differently this time is reinstall XP SP2 and SP3 BEFORE reinstalling ANYTHING else apart from TweakUI. (I don't think I used RTF viewer last XP reinstall; then, I also had a recent backup of the Documents and Settings folder to use in any case. This time I didn't).

HTH. It's a vital plugin, BTW.