GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Scripts (Perl): How To: Setup ActivePerl for scripting in Opus 11

scripting

#1

Getting ActivePerl
Get ActivePerl 5.20.2.2001 or higher from Here
Select Win32/Win64 Windows Installer (MSI) package depending on your DOpus install.

Enabling ActivePerl for DOpus scripting

  • Install ActivePerl 5.20.2.2001 or higher.
  • Extract the attached PerlScriptReg.zip, doubleclick PerlScriptReg.reg, and answer OK.
  • Completely restart DOpus (in other words, reboot).
    This should allow DOpus to use .pl files for scripting.

Adding extra packages using Perl Package Manager (if needed)

  • When you installed ActivePerl, one of the things it installed is “Perl Package Manager” (found in the menu).
  • Start it (If you installed ActivePerl to your Program Files folder you’ll have to rightclick the icon, and Run as Administrator).


  • Click the leftmost icon on the toolbar (View all packages), click the search field and type what to search for.
  • When you’ve found the package you want to install, rightclick it and select Install .
  • After you’ve found all the packages you want to install, use Ctrl-Return or File->“Run Marked Actions” to install them.
  • You can exit the program after PPM has finished installing the packages.

Using the console/command prompt to install packages
You may have to start the command prompt as administrator if you installed perl below “program files”
(or its localized name) to successfully perform the installation.
If perl is in the path, and you know the packagename:

ppm install nameofpackage

If you have additions/corrections to this, add a post to this topic.

  • updated recommended version.
  • added console/command prompt instructions
    PerlScriptReg.zip (296 Bytes)

Column: MP3 CoverArt Yes/No + 2 extract commands
[REQ] Cover art column for mp3
#2

Using File / Exit Directory Opus is usually enough, unless the ActivePerl install itself requires its own reboot.


#3

FYI: To install packages, such as MP3-Tag, you can also accomplish it in the Windows command shell directly:


#4

So with the release of 5.20, 5.16 is no longer available (for the free community edition).

Does anyone know if DO works with 5.20?


#5

See viewtopic.php?f=26&t=18670&start=20#p132069


#6

Thanks!