Scrolling Acceleration again

Please, Dopus Team, can we get rid of that new "feature" of incredible high scrolling acceleration ... ?

This reminds me a bit when Microsoft introduced "smooth scrolling" some years ago -- which however turned out to be terrible "jerky scrolling" for many users.

At least that Internet Explorer "feature" of smooth scrolling could be easily disabled, which is fine.

In Dopus however, no matter whether the newly introduced "smooth scrolling" is enabled or disabled -- there is always a very high acceleration when scrolling through file lists, as compared e.g. to Windows Explorer.

Since v9, I just can't find my way through long file lists or large folders with lots of thumbnails anymore since Dopus scrolls WAY to fast and I can't seem to hit my scrolling target at all. Makes me (literally) seasick :cry:

I use three different scrolling devices: Mouse Wheel, Keyboard Roller and Touchpad -- and the effect gets worse along this sequence.

I don't care what happens when smooth scrolling is on -- but PLEASE make the "non-smooth scrolling" setting behave like before. Just make Dopus stick to the system standard, scrollingwise.

Thanks heaps already,
David.P

Does anyone else get very rapid scrolling in Opus 9? I haven't seen it on any of my machines so it's got to be a mouse driver difference. Working out which driver(s) causes it might make it easier to track down.

I've never seen that problem either.

Never had that problem either. Are you by any chance using some special software for your mouse (Logitech Mouseware etc.)?

I have this problem with a Microsoft Optical Mouse and IntelliPoint 6.1.

I have enabled "Accelerated Scrolling" in the mouse settings. Very useful in many apps, but in Opus 9 the acceleration is quite steep when rolling the wheel a bit too fast. The acceleration is not that fast with Opus 8.

This is exactly it.

Dopus adds even more acceleration to your system settings -- you mostly only realize that if you already have acceleration enabled in your mouse driver.

Therefore, with Dopus v9, you end up with acceleration squared, and this makes up the entire problem described.

Please do not advise like "then turn acceleration off in your mouse driver". I have enabled acceleration on purpose because I need be able to scroll fast OUTSIDE of Dopus as well, e.g. in web pages, in my email application, in Word, and so on.

Once again, PLEASE just remove that acceleration code from Dopus and leave the acceleration settings to the mouse driver where they belong.

Many thanks already for fixing this,

David.P

If you have the "smooth scrolling" turned off then Opus does no acceleration and scrolling would be exactly the same as in Opus 8.

(the smooth scrolling isn't really acceleration either, technically - it's just that the rate of the scrolling increases if you spin the wheel faster. The actual distance scrolled is the same)

Jon, you have posted this before in another thread, but unfortunately it is just not the case like that.

The "additional" acceleration that you describe regarding smooth scrolling is there as well when smooth scrolling is DISABLED -- and it was not there in Dopus 8.

DEFINITELY.

Please double-check, and - please - fix.

Thank you,
David.P

Yep, I can confirm this too.

Actually, when you disable Windows wheel scrolling completely (you can do this e.g. with the MS Intellipoint mouse driver) -- the only app that still does scroll when you turn the wheel is Dopus 9.

Obviously Dopus does not adhere to the standard Windows scrolling mechanisms what might be one reason for the squared acceleration.

I'm not quite sure what you mean by this, as Opus simply reacts to the standard WM_MOUSEWHEEL messages that are sent by a mouse wheel. If you have somehow disabled the wheel and these messages aren't being sent then Opus would not scroll.

I've had a closer look and I believe I have found some code which could have the effect of accelerating the scrolling under certain conditions. I'll try and get an option put in to disable this in a future version.

I'll second this... there should be an option to turn off the scrolling in DOpus - I just bought a Logitech Revolution MX, and it has a super fast spinning scroll wheel, and the drivers also have acceleration. In Dopus, it scrolls so fast that it'll instantly hit the end of a thousand item list (where in other apps, it behaves quite appropriately). I can't seem to affect this with the smooth scrolling option.

Other than this problem, the accelerated scrolling is a great idea, but yeah, it should be left to the mouse drivers in most cases.

Are you using SetPoint 4.0?

I haven't upgraded yet but in SetPoint 3.3 I don't have any problem with scrolling in Opus with an MX Revolution. My wheel settings are below.


Yeah, exactly the same here. In the meantime however I worked around by employing an old mouse app called FreeWheel which resolved the acceleration issue in Dopus, until it gets fixed.

David.P

I am using the SetPoint 4.0 software, and I actually turned my vertical scroll settings all the way down, and turned acceleration down very low, so that it minimizes this problem. (It stilll scrolls almost too fast to be useful, however, unless you are pretty careful, and spin the wheel gently, which is hard to do even with the auto-shift set to its lowest setting).

Another thing that is odd is that directory opus didn't immediately pay attention to my driver settings in regards to scroll speed (or rather, number of lines to scroll per click). I think I have to restart Dopus before a change of these settings takes effect.
In my microsoft mouse settings (the one built into windows) i have to turn that setting down, because it often seems to want to override the SetPoint settings. For some reason it keeps going back up to a higher setting, like seven lines, which is way too high, in my opinion).

Anyways, a lot of this has little or no relation to Dopus, but it'd still be very handy to be able to turn off acceleration as it seems it can be problematic on occasions. Don't get me wrong though - great feature, but maybe it's just not Dopus's place to implement it - it should be a system wide thing.

Aahh! Lovely! This is so much better. Finally there's no fear to bump into the end of the file list anymore when scrolling :wink:

David.P

...PS: and the setting even applies to smooth scrolling.

Beautiful!

David.P

This is why GPSoft gets my money.

Thanks!

Hi everyone,

I was just going to try smooth scrolling again, but it makes no difference whether I set or remove the checkmark.

Maybe it's a little smoother in thumbnails mode, however in details mode, scrolling is still "jumpy" -- one line at a time.

Can scrolling be made smooth in details mode as well?

Thank you
David.P

The option does have an effect, but it is quite brief and subtle, especially in details mode.

When scrolling a few lines of text, if it animated in a way that lasted long enough for you to notice it, it would be quite annoying, I think.