GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Search window takes 135 seconds to display

I am a new user of Dopus and I am totally in love with the program.
The problem I have is that during the trial period I might have gone a bit overboard with my customization. Now I believe Dopus is not performing as well as it used to and I would like to reset it to the fresh install. It would be nice if I could do it without actually installing the program from scratch because that would mean cleaning up every nook and cranny of its presence. Or at least I think so.

My most immediate problem is that the search window is no longer attached to the Lister (I believe it was at some point and I liked it there) and more importantly whenever I click on the search icon or I press Ctrl-F it takes over 2 minutes for it to display.

It must be a separate process by the way because the last time I used it I had time to press Ctrl-F, Navigate around, close Dopus, reopen it and then after a bit the search appeared.
If I click on the Tools >>> Find menu Dopus sort of freezes (not responding), then after a while returns to life but still no search. After the customary 2+ minutes the search appears.

I know that when I first installed it the entire program was working a lot better so I must have done something to screw it up or something else went wrong.

If I do have to install from scratch, what other files do I have to delete to be able to get back to a clean install?

Thank you very much

UPDATE: I did find how to dock the search bar to the lister so that each time it Doesn't take that long and I found a way to reset every preference to default. However, now DOpus crashes at startup and when it Doesn't it takes about a couple of minutes to become usable. My money is on the search window.

Try the steps in these FAQs:

[ul][li]Crash, exit or high CPU usage when viewing certain directories[/li]
[li]Crash, exit or high CPU usage when right-clicking certain files (probably not relevant here but listed for completeness)[/li]
[li]General slowdown or instability investigation steps[/li]
[li]Crash dumps for bug reports (when sending bug reports to GPSoftware support)[/li][/ul]

I went through some of the steps in the links provided. Thank you. Indeed my machine is more taxed than your average windows rig, but it also has the horsepower to do it. When I first installed Opus it was working quite well and the Find lister was coming up almost immediately.

Now if it open it will take that long, but more frequently it will crash the lister I am in. Not the entire program though. I can open a new lister and work with that, but the find window won't respond.

I am thinking of doing a clean install of the program starting from scratch. I would hate to lose all my settings (by the way, trying to save my settings brings in another crash) but I can duplicate them rather easily.

I could also take a video of it, but it would be rather uninteresting. The window just grays out and sits there.

I will do a clean install and if it happens again I will go through all the steps.

The FAQ on backing up your configuration includes info on how to manually back it up if you're finding the normal config backup is crashing (which indicates something is quite wrong).

You could also try installing Opus over the top of itself, without uninstalling first. So long as you don't uninstall your config should be left alone (although it doesn't hurt to back it up anyway, just in case; it's only really one directory you need to make a copy of so it's quick & easy to do). That should ensure all components are installed and registered correctly.