Setting pdf to Adobe Acrobat in Dopus does not take

I have, in DOpus, set pdf files to open with Adobe Acrobat, and they still open in Microsoft Edge (damn app!). What can I do?

Hans L

Right-clicking a PDF and using the Open With menu to change which program handles them is usually enough.

If that isn't working, can you give more detail on what you did before?

Ah, Leo, you remind me that it was what I did before, but it obviously did not last. I did it again now, so let's see if it lasts this time.

Thank you!

Hans L

I did "Right-clicking a PDF and using the Open With menu to change which program handles them is usually enough." again, and it did not last. Let me know, please, what info you need to provide some clues.

Thanks/Hans L

If it works for a while but then stops working, some other PDF tool is probably taking it over by modifying the registry, or similar. It won't be Opus doing it as Opus doesn't change file types unless you tell it to, but there is a lot of badly written PDF software out there which could be doing it.

I think this is Edge.

Hans L

I made the change in Windows, which (by Edge) made unwanted changes.

Hans L