SFTP Connection to a specific FTP-Server not possible anymore


since last week i can not connect via SFTP to my Web-Space anymore.

Here's the Log:
geöffnet wird Verbindung xxxxxxxxxxxxxxxxx:22
Server version: SSH-2.0-OpenSSH_6.9p1-hpn14v5
Using SSH protocol version 2
We claim version: SSH-2.0-PuTTY_Directory_Opus
Server supports delayed compression; will try this later
Doing Diffie-Hellman group exchange
SSH: ssh_init: error during SSH connection setup 0
Verbindung geschlossen

Connection with FlashFXP or Putty ist still possible.

Any Suggestions or Workarounds??

Which version of Opus are you seeing this with?

Hello Leo,

I'm using the latest Beta (as always :wink:: 11.15.1 (Beta) x64 Build 5688

Any further ideas?

You said "since last week" - do you mean that you upgraded Opus at that point and it stopped working, or that it just mysteriously stopped working?

The FTP/SSH code has not been touched since May so if you always update when a new version is released for 11.15 to have broken it seems odd. Maybe something else changed on your system "last week" that could affect it?

Maybe it's not exactly 1 Week. Could also be 2 or maybe at least 3. It's summer, it's hot and my brain is to slow :wink:
Maybe this one hint. I've tried an older version of Putty (beta 0.58) and this version also fails to connect with this error message:
"Couldn't agree a client-to-server-cipher (availaibe: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com)"

the connection with putty version beta 0.65 works. afaik you use parts of putty. maybe thats the problem or something on the server side has changed???

Whether it's a week exactly or not isn't the issue :slight_smile: I'm just trying to pin down whether you think this change was a result of an Opus upgrade or something else. The FTP code in Opus has been stable since May so if you've installed a new version since May and had it work successfully, then I would say it's more than likely something that's changed on the server.

Addendum: SSH in Opus is currently based on putty 0.64 so if you could try that version it would give us an indication of where the problem may be.

Otherwise, if you can email site login details to greg@... we can take a look at it.

Connection with putty 0.64 works.
Will provide you the site login.
Thanks for having a look at it.

Thanks for the details. We'll run some tests and see what we can find.

This will be fixed in the next update. Thanks for your help!

Thanks for your time to run the Tests.
I'm happy that SFTP will work for me again.

The beta 11.15.3 is now available. Please let us know how you go!

Installed the new version.
All works now as expected.
THANKS! for your work.

what vers putty is latest build based on,

I am currently running 10, but now I need base .66 puty to access sftp sites through SSH.

Opus 11.17 was updated with the Putty 0.66 changes.