GP SoftwareTwitter
Opus FAQsManualCommandsObjects

SFTP site not displaying folders or files


#1

I'm running Dopus v12.7 build 6540 (with Advanced FTP License) and having issues viewing files on SFTP server that I'm hoping someone may shed light on.

First off, I'm successfully viewing the same site using filezilla and ultraedit without any issues so that leads me to believe its some setting or bug I cant seem to figure out in opus.

Details: connecting to SFTP site using SSH private key authentication. I can successfully connect to the site, successfully travers different subfolders and even create a file on the ftp server.
Howerver... the issue is the window that normally would show me the files or folders on the site remains blank like there is nothing there.
Looking at the FTP logs I can see where a LIST command was issued and it even logs in the ftp logs that it found 5 files but nothing shows up in the view window.

Ive read a couple other threads about enabling passive mode, using MLST vs custom LIST commands but those appear to be greyed out and supposedly not applicable to sftp connections.
Any help would be appreciated.

The ftp log last entries when connecting and attempting to see anything show this, it seems the LIST command was returned something(5 files) but the display window remains blank.

Offered public key
Offer of public key accepted
Sent public key signature
Access granted
Opening session as main channel
Opened main channel
Started a shell/command
SSH: CTS CONNECTED
SSH: Listing Directory
SSH: List complete 5 files.
SSH: Listing Directory
SSH: List complete 5 files.
SSH: Listing Directory
SSH: List complete 5 files.


#2

Does the status bar at the bottom of the file display indicate anything is being hidden?

If there is a hidden count (usually in "x Hidden" in red), click on it to toggle Show Everything mode and see if that reveals anything.

If not, which SFTP server software is running at the other end? It should say around the time the connection begins in the FTP log.


#3

Unfortunately it does not show any hidden files and show everything didnt help.
I also tried updating Opus to 12.9 build 6724 and that didnt change anything either.

I "think" our corp sftp server is running winsftp pro, but infrastructure team is gone for the day and I'll have to confirm that and what version on Monday. It does seem only related to this secure ftp site as I can hit other non public key sites just fine. This was a new site setup on the host side so its quite possible they have something off there, I just was thrown when I could use filezilla and see everything ok (using base filezilla settings).

Here is my complete ftp log from a fresh connect attempt.

Opening Connection (removed)
Server version: SSH-2.0-0.0
Using SSH protocol version 2
We claim version: SSH-2.0-PuTTY_Directory_Opus
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Host key fingerprint is:
ssh-dss 1024 (removed)
Initialised AES-256 CBC client->server encryption
Initialised HMAC-SHA1 client->server MAC algorithm
Initialised zlib (RFC1950) compression
Initialised AES-256 CBC server->client encryption
Initialised HMAC-SHA1 server->client MAC algorithm
Initialised zlib (RFC1950) decompression
Reading private key file "(removed)"
ABC Warning: Use of this System is Restricted to Authorized Users

This computer system is the private property of the Company and may only be used by those individuals authorized by Company management in accordance with Company electronic communication system policies.
Unauthorized,illegal or improper use may result in disciplinary action and civil or criminal prosecution. Your use of this system is subject to monitoring and disclosure in accordance with Company policy and applicable law. By continuing to access this system,you agree that such access and use is subject to the foregoing.
Offered public key
Offer of public key accepted
Sent public key signature
Access granted
Opening session as main channel
Opened main channel
Started a shell/command
SSH: CTS CONNECTED
SSH: Listing Directory
SSH: List complete 5 files.
Connection closed

#4

The log looks normal enough. SSH-2.0-0.0 is the server but unfortunately doesn't include the name of the implementation. (Others respond with e.g. SSH-2.0-OpenSSH_5.4.)

It's probably not a firewall issue since it would fail much sooner if Opus was being blocked from communicating.

If other programs can read the directory and Opus is talking to the server OK then it is odd that it isn't working.

My guess is that there's something unusual about the way the server is returning the folder listing, which Opus isn't handling correctly.

Would there be any way we could get temporary access to the server, or a similar one that exhibits the same problem, to debug things? If so, please email the details to crashdumps@gpsoft.com.au (or, for added security, encrypt the details and mail them there, then send a private message here with the password for the archive). If not, we could try adding some extra debugging into the code which would let you generate a log of the raw data the server returns for the directory listing, which might let us work out what's going wrong.


One random thought: Try changing the Misc > Use UTF8 setting for the site to either on or off (instead of the intermediate state, which means it tries to work it out automatically). If it's getting the encoding wrong, that could explain why no listing is coming out.

After changing the setting for the site in the FTP Address Book, please fully exiting Opus (via File / Exit Directory Opus) and then restart it before testing things, to make sure a cached connection isn't being used with the old setting still in place.


#5

Looks like the host side site is using "VShell , v4.3" as the host sftp application.

I tried the Misc > UTF* options of on and off but that didn't change the outcome. I also made sure to fully exit Opus each time and made a change. I'm trying to find out our options to see if they can expose the site and open up access so you could test this first hand but unfortunately not sure how quick or promising this is going to be yet.

As a note, Opus is for sure connecting as I can even place a file on the server provided then use filezilla to view it. It seems its just something related to not being able to view the files or folders in the lister window.


#6

I've just sent you the necessary debug package to the crashdumps@gpsoft.com.au email but I havent seen where I can send you a private msg thru this support forum with the password. Where do we initiate a private msg to you here where i can give you the pswd for the debug package?


#7

If you click my icon at the top of this post, it should show a message option.


#8

I was only able to get to the messages by clicking the developers link but when tried that it comes back saying "Sorry, you cannot send a personal message to that user" . Check for another email at your crashdump email addr, I'll just send it there.


#9

Apologies, I hadn't noticed until now that the option to send private messages isn't there until the forum bumps you to Level 1, to try to combat spam/bots.

That happens automatically after using the forum for a while, but we should probably make it automatic after liking accounts as well. Something I need to look into.


#10

No problem at all. Lol i was just trying to make sure i wasnt doing something wrong and was like man i cant even figure out how to send an email thru this support forum. Anyway, let me know if you don't see the debug files i sent thru the crashdump email or if you need any additional info. Thanks again for time and interest in looking more into this.


#11

Thanks for sending the connection details! We've been able to reproduce the problem and should have a fix in the next update.


#12

Awesome!! Thanks Guys! Unless you still need it I have to let our infrastructure team know they can remove the temporary key.


#13

That's fine, we should not need it any longer.

Many thanks for setting up access for us to diagnose the problem.