SFTP times out

Hi,
since I got DOpus I am unable to use the FTP functionality.

I can see in the FTP log that it connects to the server, the authorisation is successful but when it is attempting to read the folder it times out.

Can you please assist?

Thanks

Are we talking about SFTP or FTP? The title says SFTP but the body says FTP.

FTP timeouts when reading folders are usually due to needing to use PASV mode. The FAQ on FTP issues has more details, but may not apply if we're talking about SFTP.

Sorry I mean SFTP.

  • Does the same site work via SFTP in another program (e.g. FileZilla)?

  • Can you paste the full FTP log for us to look at? (Please remove server names and IP addresses and anything else that needs to be kept private.)

  • Is this happening with 12.6 or an earlier version?

  • Could any firewalls (on the PC itself or as part of the network) be blocking Opus from talking to the server?

Hi,

  • I can successfully connect with other applications (I tried WinSCP)

  • I use the latest 12.6 version but I had the same issue with previous versions

  • The windows firewall settings are managed by McAfee Personal Firewall according to control panel. I have disabled McAfee firewall but I still get the same behaviour

I have enabled the debug logging but I don't get any useful details. Here is the log:

Initialising SSL BIO...
Opening Connection ftp.********.com:443
Timeout on Command 1001.
Connection closed

I use an application to check the traffic on the net and what I notice is that when DOpus attempts to connect to an ftp, I don't see the process in the traffic watcher. It is like DOpus never opens a connection (or attempts to open) to the ftp.

That's the entire log?

It's likely the firewall is blocking Opus from doing any kind of Internet connection.

Does the update checker work?

Yes, that's the entire log I get.

The update checker works correctly unless it is not able to connect and just shows the last info. It says the app is up to date. The build I have is 6369. Is this the latest?

Have you got any test ftp accounts I can try?

What happens if the credentials are incorrect like the password. would DOpus produce a relevant error in the log or just time out?

Credentials won't matter if it's timing out before it can even connect.

Here are some public test sftp servers I found via google:

http://itcsubmit.wustl.edu/icons/ServerAccessTest.html

http://www.sftp.net/public-online-sftp-servers

I can't vouch for any of them but they look OK from the descriptions.

I used the first test ftp in the second link and it works correctly.

Going back to my settings I tried different things and I managed to make it work.

Initially, I was using this hostname: ftp.mydomain.com and could not connect

Now I use this: mydomain.com and it works nicely.

Thanks for the help