Simple find - not character '~' not working as expected

Any word is off, wildcards is on.

~filenameThatIsPresent
~(filenameThatIsPresent)
(~filenameThatIsPresent)

none of these work as expected, though putting Any word on and using - instead of ~ does work.

See

Filter Bar (~ Not) is not working - PrivateBeta - Directory Opus Resource Centre (dopus.com)

The 2nd should work to exclude a file whose full name (including extension) is filenameThatIsPresent.

~(*filenameThatIsPresent*) may be what you’re really looking for.

My bad, was searching for a word in a filename instead of a word as a filename (so used to have Any word checked AND it's been updated). Also must include extension. (Maybe a need for an include extension checkbox ?)
Your reply works perfectly, many thanks.