Where is the setting to enable use slide show when viewing photos the view as slideshow icon is greyed out

There isn't a setting to turn it on/off. The button should be available whenever you've started viewing pictures in a folder with more than one image file.

If there's only one picture in the folder then the button will remain ghosted.

The only settings for the slideshow control it starting automatically and the delay length.

Also, you have to open the image from within Opus for the slideshow option to be available.

If you've made the Opus image viewer the system-wide image viewer then if you double-click a image on the Desktop (or in mIRC, or whatever) it will open with Opus but the list of next/prev images will be empty and the slideshow option won't be available.

There is more than one photo in my folder but its still unavailable by the way i am using opus 6

Are you using the Viewerpane or the standalone viewer? I know that both support slideshows in version 8 - not sure about 6 - could be only the standalone viewer is supporting them.

6 is getting a bit long in the tooth - there's plenty of enhancements which make the upgrade worthwhile.

Try the version 8 trial and see if it solves your problem.

For the slide show to function, you must have multiple images. You can do this in several ways. a) Turn on Preferences - Viewer - Generate Next/Previous list automatically or b) Select a specific sub-set of images from the folder.

Does your directory contain only images? I don't use Opus' viewer, but I know XnView gets cranky when there's a non-image in the folder.

Slideshows in Opus skip over non-image files.