GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Slow context menus

Something in my Vista configuration has changed and every since, context menus in Opus are slow. They take 5-10 seconds to pop up every time, for all files and all folders except the desktop.

Prior, the first time I loaded a context menu, it would take 3-4 seconds, but after that they were almost instantaneous. I don't recall changing anything, but did have a BSOD the other day.

Anyone have any ideas?

I'm using version 9.1.1.6 (x86)

TIA

Have you read this?
[Crash, exit or high CPU when right-clicking certain files)

Thanks for the tip. I setup the DebugView and am seeing all the messages as the context menu is loaded.

However, even if I put every context menu entry into the ignore_context_menus list and now no debug messages are displayed, the behavior is still the same.

It still takes between 5 and 10 seconds to load the, now reduced, context menu.

Thanks,

Did you try turning on the Hide Windows items on file context menus option? Still the same with that on or does it remove the delay?

How many files are selected?

Do you have any offline network drives mapped?

When I check the "Hide Windows items on file context menus" option, the context menu shows immediately, but obviously without any of the menu entries.

I'm just selecting a single file and have no network drives mapped.

Thanks for your help.

To add a little more and hopefully useful information to this problem.

When I run Opus "As Administrator", I no longer have the long delay in the context menu and it works as it used to.

So I'm guessing there's a dll somewhere that doesn't have the correct permissions anymore???

Thanks again for all the help.

Since you've worked out how to use debugview in order to see the calls to the context menu handlers and have also seen the problem go away with the Hide Windows items on file context menus option enabled, you can also leave them all hidden and try adding the menu handlers back one at a time to see if one of them in particular breaks things again... Add them to the All files and folders catgory in the FileType editor using the following sort of command (which is what I have for PowerArchiver):

FileType CONTEXTMENU {d03d3e68-0c44-3d45-b15f-bcfd8a8b4c7e} CONTEXTFORCE

The CONTEXTFORCE arg at the end tells Opus to override the Hide Windows items on file context menus option for just that handler...

This might not work either, it's sort of the REVERSE way from EXCLUDING the handlers in the 'ignore' list that the steps Leo wrote up is geared towards... but it's also the way I use to clean up my context menu and move things around (order-wise) according my preferences rather than the default windows generated list put in play by the shell extensions on their own...

my 2.1234 cents...

Thanks so much for your patience in helping me with this.

I'm not able to correctly add these items back and I'm not quite sure where to add them.

Using the menu, I go to "Settings"/"File Types" which opens a dialog.

I select the "All files and folders" option, then click the "Edit" button which opens another dialog.

From there, I have tabs for "File Type", "File Colors", "Info Tip", Tiles Mode". On the "File Type" tab there is a subtab called "Context Menu", but I don't find anywhere that accepts the type of command that you suggest.

Where am I going wrong?

You're close. In that context menu section click New then in the next dialog make sure you set the TYPE to "Run an Opus function (not supported in Explorer)". That should change the dialog box to one where you can enter the command steje suggested.

Note you can also configure other context menus while in customize mode.

Thanks! That worked great. I was able to successfully add all the context menus, and they work very fast.

I'm still wondering what is going on, but at least now I have the context menus in a useable state.

Thanks again.