Slow copy; timestamps

I have two main issues with the new DOpus 8.:

  1. When I simply copy files/directories (HDD(s)) it is about 2 times slower compared to other file managing applications.

E.g.: Copy 1 Gb data costs ~60 secs (in DOpus 8)
Copy 1 Gb data costs ~30 secs (other common prg)

It is a feature or bug? How can I configure for faster file transfer?

  1. Timestamps.
    It is an exellent feature that Opus keeps the timestamps of not just copied files but folders, too!
    But, often I need to actualize the dates of the directories I copied. I can switch on/off the keep timestamps button, but I 'd like to have changed the timestamp of just the copied directories not all the files too.

Thanks a lot!

Bye,
Ateq :opusicon:

I have never noticed a speed problem when copying large numbers of files with DOpus, it zings right along as fast as anything else does. Have you played with the copy option settings in preferences? Such as disabling the progress bar which will slow things down somewhat?

SETTINGS/PREFERENCES/FILE OPERATIONS COPYING(2)

In regards to your second question, I am going to venture way out on a limb here, so what I'm about to say may not be right. But as I recall the operating system your computer is using has a lot to say about directory time stamps. For example, I don't think it's even an option in Windows 98 to modify directory time stamps. So what you're asking for may not be possible, but again I'm not positive of this.

Got any more questions you want me to not answer? LOL

John

You can use the Opus SetAttr command to change timestamps after you've copied files, if you want them set to something other than the timestamps of the originals.

If you want the files to have the current time then you can make a button with

SetAttr MODIFIED=now

which you can press and it will set all the timestamps without prompting you with the usual dialog.

If you only want the command to act on files, folders, or some more complex selection criteria, add a Select command before the SetAttr.

Regarding copy speed, Opus is as fast as anything else for me. Were you performing a fair test, copying similar -- but not the same -- files between the same pair of devices? (If you copy the same files, the second program in the test will have an advantage because the source will be cached). Was the destination becoming full or very fragmented?

If a removable (esp. USB) or network drive is involved in the copy it's sometimes worth changing the buffer size which Opus uses, but I would leave that alone unless you need to change it.

First of all thanks for the replies!

I made fair test about the slow(er) copy problem:

Copying 1 Gb (exactly 1 pc. DVD VOB file)
(from Samsung ATA/7200/80 -> Seagate SATA/7200/120):

DOpus:
67 s (Progress bar show on)
41 s (Progress bar show off) (default set., max. speed)

Tcmd:
25 s (default settings)

I'v repeated it one after another 4-5 times (+/- 1 sec diff)
I think it's sigificant.
Unfortunately, I could not find any settings which speed up the copy process (Incl. file operations/copying(1-3)). Playing with the buffer size does not significant.

Anyway, have any of You done simiral tests of this matter?

Timestamps (in copy case):

I did not mean of the timestamps attribute modification!
I think of the simple copy. Eg.: you select any dirctory and copy to somewhere else. In this case DOpus keeps the original date of the directoy, but I do not want this for many cases. I want the directory have the copied date/time, and not changing it manually.
This thing does not exists in any other program or the early DOpus.
I would like to switch this feature on/off like for the files in the file operations/copying(2).

Ateq

I experience slow copies as well with Dopus. This was happening to me in 6.0 on my old machine and is now happening on my trial version at work and also my home machine. 120 mb file copied first with explorer to a local folder took 15 seconds then deleted the copied version and then copied another identical 120mb file with dopus to the same location and it took 24 seconds.

I just ran some more tests and when disabling the real time scan on my virus scanner the difference between copying with dopus and explorer was far less. Seems the virus scanner handles the way Dopus is copying differently from explorer and it is causing it to significantly slow down the copy. I am running Trend Micro's antivirus btw and on my old system running dopus 6 that used to run Norton I believe.

I didn't get too crazy but these tests but they seem interesting.

Virus scanner or similar program was not installed when I created the test. I do not know what causes the 50% speed drop, yet.
In your case the 120 Mb at max. 8 Mb/s could affect the results (slow or fragmented HDD). Maybe the difference on higher speed (~30 Mb/s) could be much more significant.