GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Slow file processing mobile device


#1

I recently joined the mobile revolution and got a Samsung G3. I use the camera.
transferring jpg files from the phone from to the PC via dopus is a pain. V 10 or 10.5, I can see no difference.

Let me explain. I plug the phone in to the PC via USB, I get the friendly "what do you want to do" window from Microsoft.
I close it and open a lister (dual pane) I select the phone, then the card on the phone, then the camera directory.
Dopus enumerates and displays the files fine, but when I try to copy or move one, there is a 30-60 second delay, and the lister goes whitish as it processes.
Eventually, it will allow me to move/copy. I can view the files in a viewer immediately, but cannot move/copy them without a delay.

I have no such restriction in Explorer.


#2

Make sure the Portable Devices folder format is turned on, and that it only has basic filename, size and date columns, not anything that would cause the files to be opened and inspected (e.g. Description, Width, Height, thumbnails, that kind of thing).



#3

Thanks.. tried that.. no change. Once the phone has been "scanned" by Dopus, it does it with no issue.. until I disconnect and reconnect the phone, then it does it again.
I had filename, size(auto), ext and date modified selected. I removed ext and still no change


#4

The extension column should be fine.

Could you post a screenshot of your lister? Maybe there's something else turned on which is causing the delay.

MTP only lets you send one file at a time, so if something is triggering lots of files (or one big file) to be downloaded then it can block other things from copying to or from the device.

Make sure the phone is not asleep or screen-locked, too; those can block MTP access and sometimes instead of just failing the API takes a long time to realise instead.

Occasionally the PC side or the phone side seem to get confused and I have to fully exit Opus and restart it, or even reboot the phone. (Can happen with Explorer as well.)

You can set Preferences / Miscellaneous / Advanced: mtp_enable = False to make Opus use Explorer's MTP support instead of its own. With most devices it's not as good but it seems to improve things with some devices.


#5

sure, heres a simple screenshot. This is with mtp-enable = true

I tried the mtp-enable = false and the problem was gone!... but my sort columns were different, of course... MS, I expect.



#6

Thanks for the screenshot.

I can't spot anything which might cause a slow-down, so I think using mtp_enable=false is probably best with this device.