Slow launch, Win7 64

The first time I launch Dopus (by any means) after booting Win7 64, it takes nearly 5 seconds for the lister to appear. After that initial delay, Dopus will launch virtually instantly for the rest of the session. Next time I boot, it's the same behavior: hangs on the initial launch. I see the same thing with the address bar drop down menu.

It's only a minor annoyance but I'm guessing it's not normal behavior. Any suggestions?


I can only guess but with a 5 second delay my guess is that you have something in you Opus toolbars or configuration which is pointing to something on a HDD which has gone to sleep and takes 5 secs to spin up again.

Just a guess, of course. It could be other things.

Using Process Monitor to see what Opus is accessing during the wait may tell you where the wait is coming from.

It's not just that the first time you launch Opus it's not actually running already, whereas afterwards it is?

Leo, HDs are not allowed to sleep so it's not waiting for spin up.

Jon, I have Dopus configured exactly the same way on an XP machine (in the process of migrating to a new Win7 box) and I don't see this behavior on the XP side. DOPUSRT is loaded and running on both machines at boot.

EDIT to above. I was wrong. DOPUS.EXE is loaded at boot in XP but not in Win7, even though both are configured as Explorer replacements. So Jon has hit paydirt here. How to I get dopus to load at boot?

Preferences / Launching Opus / Startup / Launch Directory Opus automatically on system startup

5 seconds is still quite a long time to start, but if turning that option on solves the problem well enough for you then it's probably not worth worrying about.

That pref (Registry entry?) was already set but not functioning, so I did a workaround by dropping a shortcut to Dopus.exe into my startup folder.