Slow on one machine (was: Slow after W10 Update)

The threshold update has only just been released - MS delayed it. If you are certain you have the upgrade I believe you, but I think you might want to double check. And again, this is happening on two separate computers. The only thing they have in common is that both were updated to the W10 upgrade yesterday. Anyway, thanks for the prompt response. I'll keep an eye on the forum to see if others start to have the same problem.

[Consolidated replies into a single post for clarity.]

Threshold 2 was released a while ago, then pulled for some reason a few days later, then reinstated a few days after that. We've been running it since the initial release and it has been almost a month since it was reinstated, with no similar reports, so I think it is a coincidence, or an interaction involving a third component or configuration detail.

One thing you might want to try is doing a config backup, then completely uninstall Opus, reboot, and reinstall it. That will revert the config to defaults, and it's worth checking if you still see the problem in that state. If not, you can restore the config backup and get back to where you were.

Hi Leo,

I uninstalled and reinstalled on my desktop. As soon as it started (unconfigured) it was very slow. I'll live with it as is, but thanks for the response(s).


Please disregard my previous post (where I say I can use it as is) - I can't - the delays are really annoying. But I've noticed something as I've been playing with it trying to see what's wrong. Here are some observations:

  1. When the lister first opens it is set to open at c: drive. The right pane populates normally, but c: drive takes time to expand in the folder pane on the left - and it expands one ----- folder ------ at ------ a ------ time (like that).

  2. If I try to open a location using my Favorites list, it takes several seconds for the location to open. BUT - if I open the same location from the folder tree, the location seems to open normally. After that, the same location will also open quickly from the favorites dropdown.

This problem is limited to Directory Opus - it is not replicated in Windows Explorer or a different 3rd party browser I just downloaded as a test.

Thanks again for your time and assistance.

Did you try disabling all shell extensions, or booting into safe mode?

I'd include the Microsoft ones these days, too. We recently diagnosed a problem where a serious bug in one of the shell extensions that ships with Windows can cause threads to stop being able to start or stop in a process. I don't think you are triggering that problem, but it shows that even Microsoft are not immune from putting out bad shell extension DLLs now.

It sounds similar to this thread : [Folder Tree expansion slow w/ Microsoft Security Essentials)

Maybe try disabling your antivirus and see if it makes a difference.

I tried disabling Kaspersky (KAV, not KIS) and that made no difference. But I'm now fairly sure that aside from the slow population of c: drive in the folder tree, the slow loading of locations is isolated to my favorites dropdown list. I'm going to clear that list and repopulate it one location at a time and see if that makes a difference.

As for the shell extensions - no - I only disabled those I don't care about (including those identified in the link you pointed me to in the second post of this thread)

Okay, deleting recreating favorites didn't help.

I need to apologize - I just rechecked the laptop and it is fine. Not certain why I thought the problem was duplicated there, but it is not - it's only on the desktop. Also, JUST AS A TEST I installed Directory Opus on another desktop system running W10 and upgraded that system to Threshold - and there were NO problems (I then ununstalled the app so as not to violate the EULA).

It seems the issue is isolated to the one desktop. It is virtually a clone of the 2nd desktop I just tested (same startup items, AV, new high-powered systems, etc). I'm fairly technical (on staff at multiple Windows support sites) and am stumped.

Did you try disabling all shell extensions, or booting into safe mode yet?

The problem is probably caused by a shell extension, so you need to either rule that out or find out which one is causing it. There's no avoiding that.

Safe mode works fine. I do understand the implications of that, so.....

  1. Tried disabling all shell extensions - no change

  2. Changed some services to manual as appropriate

  3. Tried selective startup (msconfig)

  4. Disabled everything (except key windows services) in Task Manager

  5. Even tried changing screen resolution

No Change.

Did you reboot after disabling all shell extensions? A reboot is needed after disabling them, since they'll already be loaded into the process in some cases.

Is Windows Defender running in addition to your anti-virus?

Uninstalling the anti-virus is worth a try, in case it does not disable properly. We've seen this a few times, and it's also usually one difference between safe mode and normal.

If there's high CPU usage during the delay then Process Explorer can be used to see which DLL's code is using the CPU. Ask if that seems applicable and you need instructions.

If the slowdown only happens with particular folders (e.g. ones full of .exe installer files, or full or archives, or video files) then that can point to certain things over others.

Yes, of course. I rebooted after every change.

No, Windows Defender is disabled.

I've disabled KAV with no change. KAV also provides the ability to completely close the app within the gui and I've also tried that (no processes remain in Task Manager). Uninstalling serves no purpose.

CPU usage spikes slightly when Dopus loads, then settles down immediately. The process that jumps is Dopus.

The slowdown occurs with only a few of the favorite shortcuts, but one of those folders is empty. And again, please remember this is tied to the fact that the folder tree is slow to populate. There is a spinning blue circle in the upper right of the lister as the default drive (or other selected drive) populates.

Unisntalling serves the purpose of checking if KAV actually disables itself properly.

Several AV tools do not and still cause slowdowns even when disabled, as I said. There's only one way to find out if that is the case. If it isn't, install it again and we can move on. But if it is, and we don't test it, then we will never get to the answer as we're intentionally avoiding testing a possible answer.

How to find components causing high CPU usage has instructions on how to find out which component is using the CPU within the dopus.exe process. That may point in the direction of a particular driver or DLL.

However, it the CPU usage is not high for the duration of the slowdown, then this is probably not worth trying.

Try turning off everything under Preferences / Folder Tree / Contents to minimise what's shown in the tree. Does that make any difference?

Also, try turning off Preferences / Folder Tree / Options / Automatically expand to current folder.

If you hover over the spinning circle, what does it say?

That circle usually means the file display is being populated. Which columns are shown in the file display?

Does the spinning circle show even in the empty folder?

Sorry leo, guess I'm seeing things that aren't there. The blue circle spins for only a few seconds, and only when the lister first opens. Hovering over shows nothing.

I've already tried fiddling with all of the folder tree preferences with no success.

Not to be obstinate - especially since you are being so kind with your time, but I'm certain KAV has nothing to do with the issue. If it did, it would effect all favorites, not just a few. And again, the cpu spike is minimal (goes from 2% to 12% and then back to 2% within seconds). It does NOT spike when clicking on a problematic favorite.

An additional question if I may. How do I display the Homegroup? Thanks.

And out of respect for the time you are spending with me I did uninstall KAV, rebooted, opened a lister and had exactly the same problem. I then reinstalled KAV. Any other thoughts? Thanks.

Sorry to keep posting, but here's another update - I restored an image to a point just before I upgraded to Threshold and low and behold the problem was there then too. It looks as though I've given you some bad info at several points in this thread and I do apologize for that. Bottom line, however, is that I still have the problem and have tried everything you've suggested with no improvement. Oh, and I was able to check the message over the spinning blue circle: "Querying File & Folder Information"

It might be worth running Process Monitor to see which files and registry settings are being accessed during the delays.

If you run ProcMon and save a log in .PML format, we can look at it for you. (They are often large, but zip down to fairly small sizes.) Make sure ProcMon is set to monitor file and registry, and don't filter out any processes as the delay could involve waiting for a second process to do something.

Logfile attached. Candidly, not sure I did it right - hope I did.

[I removed the log after downloading it, just in case there's anything private in the file paths, usernames, etc. --Leo]