Slow SFTP upload speed

A final post on this: I contacted the server-side, they checked and couldn't find anything wrong with the settings or provide a suggestion on changing something on DOpus - everything seems regular. So, I'll have to use another FTP client.

Tried DOpus 12.0.5 - problem remains.

Have you seen faster speeds with another SFTP client?

Thank you. Yes, three other SFTP clients achieve full speed on the same server (as does DOPus 11/12 in standard FTP mode). DOpus SFTP reaches about 40% of that speed. This is on upload only - download is ok.

Possibly a network buffer/window size or latency situation that our code isn't dealing with as well as the others. Unfortunately, I do not think those things are adjustable for SFTP at the moment.

(There is Preferences / Miscellaneous / Advanced: ftp_copy_buffer_size, but I am pretty sure it only affects FTP and not SFTP.)

Sometimes firewall software treats different processes differently, but it seems fairly unlikely it would be slowing down SFTP and not FTP in the same process, and only in one direction, in one process.

Ok, thanks for answering. Hope you can improve on SFTP in the future (please also consider site-to-site for SFTP).

I tried to disable and uninstall my firewall but there was no change. Also tried Safe Mode with Networking.

I have been having this issue with dopus for many years and so have others. They know about it and have not done anything :frowning: I just use WinSCP now.
Some of the other threads:
2014: Very slow FTP
2015: Sftp is very slow


I had this problems for years too (I bought all versions since 9). Using SFTP upload, DO is really slow compared to other programs. Problem is on local LAN connections as well on remote WAN connections. Even if with small files (20-30 megs) the upload speed is slow sometimes ten times slowers than other programs (i.e WinSCP or Filezilla).

I tested the shareware version 12 of DO (I still have to buy the upgraded license) but it's still slow.

1 Like

Ya. Not sure the reason, but since they have known about it for so long and we have to pay extra for advanced ftp features its been a real sore point for me.

Unfortunately, the problem remains in the latest 12.2 version. SFTP downloads seems to be ok here (multiple connection and/or segment downloading would be better but that's not the issue here), but SFTP upload speed is problematic.

Hi - I recently paid the extra fee for the advanced FTP functionality, because I was hoping to not have to use FileZilla any more.

With FileZilla, I typically get about 50-100MB/sec upload speed (it's a gigabit connection) to my offsite server. However, with DOpus, on the same server I only get about 0.4MB/sec (400kbyte/sec).

Is there anything I could do about this?

EDIT: additonal info:

  • I am not using any antivirus or realtime scanning
  • I have tried disabling windows firewall, no change

I don't know why it would be that slow, sorry. It's much faster here, FWIW.

FTP? SFTP? Perhaps more server details could help.

I don't know either, that's why I'm asking here @Leo

Per thread title, this is SFTP. Nothing special about the server, in FileZilla I just put in the IP and user/pass and it works fine. I'm talking about single thread speeds, not multi-thread.

If I can't get DOpus to upload faster than half a MB/sec, the advanced FTP feature isn't much use to me. I'd love to figure out why DOpus is slow when FileZilla and other clients to the server are having no speed issues via SSH/SFTP.

Not sure if this would help, or whether developer's are aware of the TGPuttyLib SFTP library, but it may offer improved SFTP speeds.As @Leo is getting fast speeds though, it would be useful to know why some people aren't. As @AmigaOpus says, maybe more server details plus logging info might help debug the problem.

It's likely the same as we're also using code based on PuTTY. :slight_smile:

Leo is there interest from your team in figuring out whether DOpus is the bottleneck?

There is but I'm not sure what we can do from here to diagnose where the issue is.

Here is some additional information from my testing.

Both tests use:

  • FileZilla default settings for SFTP.
  • DOpus default settings for SFTP.
  • 2gb .7z file
  • Testing upload only

Test 1:

My remote server, SFTP, no special settings. No proxy. Local machine is on Ethernet.

FileZilla - 32 MB/s
DOpus - 0.4 MB/s

Test 2:

My LAN linux server on a SoC via WiFi:

FileZilla 3.3 MB/s
DOpus 1.7 MB/s

What other information can I offer?

Is there a way to know which SFTP version DOpus is using, or is this unrelated or entirely up to the server? I cannot find it in the FTP log.

For example, while using WinSCP (on a server with slow DOpus speeds) I see SSH-2 / SFTP-3.

Could you try the same file using PuTTY's SSH tool? That would be close to what Opus is using.

While uploading, is there any unusual activity in Task Manager for Opus, the network, or any firewall/antivirus software that's running?