(Solved) Right click, "open with" on text file not working


On certain file types (mainly text-based files), right-clicking and doing any function that utilizes Windows' built-in open-with functions do nothing (this means the actual open-with menu and things like Sublime Text/Notepad++'s custom "Open with" context menu items). Nothing happens after I click on it, except the context menu goes away.

The "Open with" context menu items all work fine from the actual Windows File Explorer. It just affects Directory Opus.

This worked previously with 12.21, however I was on Windows 10 1909 previously. I upgraded to 20H2 about the same time I upgraded DOpus. However, I have since done a dism/sfc repair. All system files are clean.

Please advise if there's something I can do to restore this functionality.

Most likely the .txt filetype is messed up in the registry, since Opus doesn't handle the Open With menu differently for different types (and it's still working fine for me, at least).

If you want, create a diagnostic of the .txt registry settings and we'll see if the problem in your registry can be found from that. To make one, go to Settings > File Types in Opus, then use the menu at the top of the dialog to open File > Diagnostic.

Opus_FTD_File_txt.zip (86.6 KB)
Here is the file requested.

I should note this isn't just affecting txt files. It also prevents the "MediaInfo" program from working with video files. I can't right-click on a video file and choose the MediaInfo context menu item (It shows up but does nothing). This is not a filetype issue, as it is not the default program it opens with. It simply won't forward the file to MediaInfo. (The program doesn't even open)

Thanks for the diagnostic.

The registry looks OK from a quick look at least.

If it's not just affecting Open With or .txt files, and not allowing you to launch some programs, or documents in some folders (or in general), then it could be an antivirus issue. Windows Defender has been causing people problems recently.

Try whitelisting dopus.exe in Defender (or the antivirus you use). If it is Defender, note that there are separate whitelists for the actual antivirus part and for the "Protected Folders" aka "Privacy Guard" parts; trying adding dopus.exe as an exception in both places.

(Adding the program you're trying to launch may also be worth a try.)

I tried whitelisting in Avira, as well as overriding all of Windows 10's Exploit protection to be off.

The issue still happens.

I did not have this problem with Windows 10 1909 and DOpus 12.11. I can't recall if I was not having issues with 12.11 on Windows 10 20H2.

I don't think it's caused by the Opus or Windows versions alone, since it's working OK here with Opus 12.22.2 and Windows 10 20H2:

The signature used to sign the program changed in 12.22 (due to being renewed, which causes some antivirus to view Opus as an "unknown" application with no trust built up yet, and then start blocking things. Other than that, nothing that affects this should have changed recently.

Looking at your registry diagnostic again, there is an OpenWith entry pointing to something which no longer exists (emeditor64):

64 HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.txt\OpenWithProgids: "emeditor64.txt" is REG_NONE

But as far as I can tell, that value being there should not break things.

The registry values pointing to Sublime are running it from here, which presumably matches where it is on your system:

C:\Program Files\Sublime Text 3\sublime_text.exe

As a workaround, you could add right-click menu items (or toolbar buttons, hotkeys, etc.) in Opus which run sublime directly on the selected files:

"C:\Program Files\Sublime Text 3\sublime_text.exe" {allfilepath}

Or possibly this, if Sublime doesn't let you pass more than one name at once:

"C:\Program Files\Sublime Text 3\sublime_text.exe" {filepath}

Well after your mention of shell extension progID's, I started digging, and I found the culprit. Apparently the QuickSFV extension prevents some openwithprogid's from firing. This doesn't seem to happen in File Explorer, but I came across a superuser answer that mentioned that some shell extensions cause problems with other extensions, specifically with the 20H1 Windows 10 update which I did not have previously. QuickSFV was the first mention, and I happened to have that installed, so I tried uninstalling that. Sure enough, problem solved.

I think I don't need it anymore, but it might be worth looking into seeing if there's anything you can do to mitigate this, since it only happens in DOpus. But I understand if it's not your concern.

Thanks for the ideas. Ultimately, they led to solving the issue. I'll mark this solved once you see this, since I figure you're curious.

1 Like

FWIW, I tried with both the QuickSFV marked "current" (2.x) and the "development" (3.0) versions installed, and didn't see any issues with the Open With menu. But it could be a problem that only happens with some additional factors.

I did notice that the 3.0 version won't even open when launched on my system, so something seems up with that version, even if not the same issue.