[Solved w/] F5 oddity

I'm in a folder in a lister in the Explorer style, and am trying to Refresh. I hit F5, and I'm taken to the root of the C drive in the Explorer Folder Tree.

I try likewise in a folder on another drive. F5 refreshes as expected.

I'm flummoxed - any ideas?

I updated to x86 on Vista.
F5 refresh works in the folder tree under the built in Explorer Style.
Everything else works just fine here too.
Doesn't matter at all what hard drive I'm really looking at.

Curious, are you using a USB drive to launch DOpus ?

If so, is there another installation of DOpus on that computer ?
I'm just wild thinking at this point ... no real reason to this ...


Thanks for the response. Nothing special here; standard install.

I've looked through prefs, toolbars, but can't find anything. F5 is defined as Refresh.

What if you disable that F5 = Refresh hotkey... does hitting F5 then still take you to root?

No, disabling F5 -> Refresh prevents refresh and movement to the root as expected.

Re-enabling returns the problem.

What's the folder? Anything special about it?

Ah, that's the ticket.

Special folders such as C:\Users<user>\AppData\Roaming and C:\ProgramData cause the problem. My testing just happened to only test these.

DOpus sets the folder to the first non-special parent folder (not necessarily the root).

Are you able to reproduce w/these?

No I don't seem to be able to reproduce it :frowning:

A question - does it happen if you turn the folder tree off?

No, only when the tree is enabled. I'm using the stock Explorer style.

Try drilling into a real (i.e. not a virtual or junction) child folder in C:\ProgramData and repeating there.

Part of the clue may be that ProgramData does not appear in the tree, but does appear in the lister whereby one can drill deeper, and then it appears in the tree. It is when within such a folder that the problem occurs.

Can you post screenshots of your settings in Preferences / Folder Tree / Appearance and Preferences / Folder Tree / Options please?

Here you are.

Hast thou been rendered stumped? :slight_smile:


I think I can verify this.
I've uploaded Video. It's only a raw avi screen capture so the file is large.
Can you download 40 MBs of AVI ?
The link is here for a short while.
I'll get screenshots up if this is it.

Using Vista 32.

Edit note: I changed the download to a zip file.
The zip file is 19 MBs.

Here's my version showing the issue. The jump to Local Disk (C:) occurred immediately upon hitting F5.

Video: 9.1Mb

[ removed video, no longer needed ]

My version is uploaded now, I'm looking at yours as well.

Enabling Preferences / Folder Tree / Appearance / Show in Folder Tree: Hidden Folders, prevents the jump in the tree.

The refresh seems to update both the Explorer tree and the lister contents; so I think without this option enabled, the refresh of the selected item in the tree and the corresponding lister contents cannot be refreshed, hence DOpus aborts and moves the selection to the parent directory.

Very good as usual MrC.
Yes, that option does fix the verification I posted !

It perhaps should be noted that this appies only to the keyboard F5 refresh.
That of course was the topic of this thread.
By default keyboard F5 = Go REFRESH=source .

I must point out though that in the example I posted at least,
with Hidden Folders in Tree unchecked,
refresh worked without the jump in the tree using the simple button = Go REFRESH .


Thanks, we've been able to reproduce it now and will fix it in the next version.

Cheers to all!

Fix confirmed w/ Thank you.