Sort by Modified doesn't display correctly?

When I sort a folder by Modified column, DO incorrectly shows like this:

whereas it should be like this:

How can I fix this?

You can change the settings for your folder format so that folders are not sorted to the top.

In case you can't find it:

Thanks for your reply. I tried that setting but doesn't work.

Kindly look at this short screencast:
and tell me if I am doing something wrong.

If you only want to make the change temporarily then you should do it via Tools -> Folder Options, rather than Preferences.

Changing a format in Preferences won't affect any existing windows until you change directories in them. It'll also save the change which you probably don't want in this case.

If you want do this a lot then it's probably worth making a button or hotkey like this:

Set SORTORDER=Mixed SORTBY=modified

You can make another button or hotkey which returns everything to normal:


I want descending sort option always to be mixed mode (not folders first).

Anyways, I've created a hot key with the code you provided...when I press the hot key, the sorting still is not proper.

Here is a video:

Notice that even though the mode is mixed now, the sorting is not descending. For example, the first file in the list dated 29/Apr/05 appears above the second item which is dated 15/Dec/06.

Either:[ul][li]Add SortReverse=On to the first command and SortReverse=Off to the second command if you want to sort in the opposite direction.[/li][/ul]Or:
[ul][li]Go to Preferences / Display / Fields and change the default sort order for the Date and Date/time columns.)[/li][/ul]

(Don't do both as they'll cancel each other out. :slight_smile:)

I tried following the 2nd option you listed above. Now irrespective of what I set the default sort order for Date(Modified) column, every column is sorted in reverse order.

For example, when I try to sort by Name in ascending order, it gets sorted in descending order. So is the case with Date column. Pls check the screenshot below:

Is the problem just that the sort arrows are the opposite way up to what you expect them to be? If so, see this FAQ:

[HOW TO: Change the direction of the sort arrows)

Thanks. That's exactly what I was after. All seems good now.