GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Speed of viewing Word/PDF files


#31

Did the attachment work?


#32

Web browsers can’t usually display DOC and TIF files.

Try PNG, JPG or GIF.

I’ve converted the TIF to a PNG for you.

As it’s showing a Hex view and not the Excel spreadsheet, I very much doubt that MultiView is working on your machine!



#33

I have similar questions about the configuration of the Multiview plugin.

Here is what I see:

Of all the file formats, Word files are the slowest to render. A few seconds. This does not seem to vary much if I change the order of the ActiveX and Multiview plugins.

I have just tried the X1 viewers. The experience is very similar.

There is clearly something going on in DOPus. Instead of taking a few seconds, the rendering in X1 and in Explorer+ and Powerdesk Pro is pretty well instant. Perhaps it is because DOPus is creating a “temp” copy of files.


#34

How long does it take to manually create a copy of one of the files you were viewing? If Opus is creating a temp copy it shouldn’t take longer than doing it by hand. If creating the copy of a Word document takes a long time it’s probably due to anti-virus scanning inside the document.


#35

Also,

  1. Are you sure MultiView is being used in that case? Do the viewers look different depending on the order?

  2. If you view a sequence of .DOC files in a row, is it slower than Powerdesk only for the first file, or for all of them?


#36

Apologies for not responding sooner. I started to reply and then Firefox imploded. Apologies also for hijacking the original discussion.

Yes. I have changed the order of ActiveX and MultiView and tweaked the formats that each viewer handles.

The results differ, for example in the “right click” options available for each viewer and in what it looks like, although I can set both to look “WYSIWYG”. In the MultiView sessions, I can see the same options that I see when using QuickView.

Another way of confirming this is to switch between viewers using the “right click” options in the viewer status bar.

Having just run some more experiments to confirm this, MultiView renders Word files much more rapidly than ActiveX.

Always the same slow behaviour. Powerdesk and Multiview are instantaneous. ActiveX always has a delay.

But as I said to the original questioner, and the reason why I chipped in, the delay is a few seconds, unlike the huge delay he complained of. Not really serious enough to be off putting.

You also asked:

A lot less than the delay in DOpus.

By the way, the reasoning behind creating a temp copy of Word files seems to be that you have to do so so that DOpus can delete a file. This does not seem to be the case in MultiView. It deletes just fine. Is it also "temp"ing?

By the way, I saw that there is a new version of the ActiveX viewer set. Maybe I should install that before continuing with this feedback. The issue may have gone away!

Hope all this helps. Sorry for rambling on.


#37

Thanks for the info, should be useful in working out where the difference comes from.

The recent ActiveX plugin update won’t affect its speed.


#38

I forgot to add that I also turned off my AV software (Sophos) to test that theory. No change.

I also shut down all the other junk that I have running to see if that might accelerate the rendering process. Again, no noticeable effect.

By the way, xls files seem to render pretty quickly, still slower then MultiView. But I use Excel rarely and have only small files.

Another thought, could Word be doing things with its autoload templates? Maybe the bits that Adobe uses to convert .doc to .pdf?

This might be a factor if ActiveX has to invoke Word to any great extent.

Let me know if you could use any further messing around with things.

For example, I wondered about trying alternative viewers to QuickView in DOpus, to see if they were also slower.

I can’t see how this would provide you with useful information. It might help folks trying to configure alternative MultiView tools. But maybe we can wait for them to turn up with questions.


#39

Oh dear. You are a horrible person for getting me started on this detective tale. I have paying work to do!

More evidence. But you may have it already from the first poster, who seems to have vanished.

If Word is open, DOpus renders .doc files almost instantly.

Looking at Task Manager, DOpus with ActiveX is loading and unloading Winword.

You probably knew all that, I am just trying to understand it myself.


#40

[ul][li]Regarding the ActiveX plugin:

[quote=“michaelkenward”]If Word is open, DOpus renders .doc files almost instantly.

Looking at Task Manager, DOpus with ActiveX is loading and unloading Winword.

You probably knew all that, I am just trying to understand it myself.[/quote]
You were researching something I had already explained in the first paragraph of the first reply to this thread (excluding the two replies from Bryan adding more info to original post before anyone else had said anything):

[quote=“leo”]If Word and Adobe Reader are what’s being used to view their respective formats then (of course) they are what the ActiveX plugin has to load to view those formats. If they are already loaded and running then the plugin doesn’t have to load them as they are already there.

If you want to speed things up you can use something else to view the formats.[/quote]
To reiterate: The ActiveX plugin will be slow if it needs to load Office because loading Office is slow. If you have Office 2007 then the ActiveX plugin will use the preview handlers which are very fast (but not available before Office 2007). If you don’t have Office 2007 and want faster viewing then the MultiView plugin is the best bet.

[/li]
[li]As for the MultiView plugin:

Try the new version of the MultiView plugin that is attached at the bottom of this post. It eliminates the delay when you switch from .doc to .txt to .doc (and similar). You will only see that delay if you have not used the MultiView plugin for several minutes.

I made a video showing the sort of speed that I get with this new version: MultiView_Speed.zip (4MB, WMV)

I tried on my year-old Vista Desktop and my 3-year-old XP laptop and they were about the same speed. There is about a 1.5 second delay the first time MultiView is used and after that it loads things almost instantly, even if the viewer is closed and re-opened. (Half the doc files were copies of a large ~600KB document, too.)

I used the DLLs which came with the installer that IzDwku linked. They’re reported as version 8.1.9.4407 in the MultiView config window.

(This new MultiView DLL also ignores XML files as I noticed the old one did a diabolical job of displaying the format.)[/li][/ul]

Edit: I’ve deleted the attached DLL to avoid having old versions kicking around and confusing things. It’ll be included in the forthcoming Opus update.


#41

Hi Leo and Michael,
Thanks for continuing the exploration of this issue. I didn’t have time to explore further, so just have Word open when using Opus to avoid the viewing delay. After your last post, I downloaded the new Multiviewer, but it made little if any difference. However, I find myself using Powerdesk most of the time because of these issues with DOpus - I hope you can fix them sometime soon!
Cheers, Brian


#42

If opening Word makes a difference to the delay then you must be using ActiveX and not MultiView.

See also my 7th July reply above.


#43

Brian:

Go into the plugin preferences (Settings / Preferences / Plugins / Viewers) and turn off the ActiveX viewer.

Then make sure you have installed the new multiview plugin and restarted Opus.

Then try it.


#44

Yes, I’m using ActiveX most of the time, except when I test Multiview!


#45

I doesn’t look like you’ve got the MultiView plugin working unless something has changed since you posted the screenshot showing a hex view for Excel files.

Go into Preferences and turn off the ActiveX plugin, then make sure the MultiView plugin is turned on. Also, ensure the MultiView plugin has found the required 3rd party viewer DLLs by selecting it and clicking Configure.


#46

To clarify further, you should see something like this when you configure MultiView:

If it says Viewer DLLs could not be located then you need to click Locate and point it at the “Filter” DLLs which came with PowerDesk, X1, Yahoo Search or whatever.


#47

OK, so Multiview was not installed correctly – thanks Jon for your jog to check this. After installing, restarting Dopus, and configuring Multiview, it worked very well – opening all types of files instantaneously!!

However, everytime I open DOpus after it has been closed, it shows the files in Hex, and I have to go into the configure menu for Multiview and then close it. I don’t have to actually go in and change anything, but the mimimum I have to do is open the configure menu then close it. Once I have done that, all files show properly and FAST!

What could be causing this weird behavior? It continued after a re-boot of my computer as well.

Brian


#48

I have been meaning to create a list of the places where these DLLs live. I use QuickView Plus, as in your example.

A quick browse suggests that PowerDesk hides them somewhere. DOpus MultiView does not detect them in the obvious places, the PowerDesk folders in Programs"

In X1 they are here:

C:\Program Files\X1\Stellent\Filters


#49

Open the MultiView config window, make sure it has the DLLs located, then click OK.

Now type this into the location field in Opus:

/dopusdata/ConfigFiles/Plugins

There should be a file called multiview.oxc whose contents look like this:

<?xml version="1.0" encoding="UTF-8"?> <multiview> <viewer_path>C:\Program Files\X1\Filters</viewer_path> </multiview>

Do you have the file? Is the viewer_path part correct?


#50

Leo, that all looks correct!