Standalone Viewer displaying hidden images

Hello everyone,

Is the Standalone Viewer supposed to be displaying images that are hidden (h attribute set)? I don't recall that ever happening before, but I could be wrong.

Pretty easy to test. Take 2 images and place into a folder. Set the 'h' attribute on one of the images. It should disappear (depending on your settings). Open the 1 remaining image in the Standalone Viewer. Hit the button to view next or previous image (depending on your sort order and options). For me, I can see both images. I would think the hidden image should also be hidden from the viewer.

I couldn't imagine I went years without noticing this :slight_smile: If I did, is there anyway we could get an option that could skip hidden images?

Directory Opus Pro 11.10 Build 5466 x64

Notice in my screenshot that it's on image 2/2 even though the display only shows 1 image. Plus the name is different. No custom folder formats for this test folder.


Showing hidden files and Attr column:


Nothing has changed, these have never been hidden by the viewer.

Thanks, Jon.

Wow. Can't believe I never noticed before. :slight_smile:

Here's my +1 for the option to skip hidden files or to only build the list of images from what is actually being displayed.

I also never noticed that before, but maybe I just don't hide my images. o)

I guess you can prepend "Select ALL" to your "Show" button, so that the viewers list is equal to what's currently visible?

With DO12's viewer updates, maybe this could be added? Where the viewer only acts upon the currently viewed list.

Sorry, tbone, I never noticed your post before. I guess this does work but only if I run this from a button/hotkey. I've always used double-click to start viewing images.

You know what, a button isn't to bad. I can get used to it. It also gives me the option to quickly view visible and all.

Thanks, tbone. Sorry I didn't see this sooner. Only a little over a year late :slight_smile: