GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Start up time - into minutes


#1

Hi. I'm having problems with Opus. Start up time has been getting steadily worse and worse and now it's into minutes to start up. I tried to uninstall/reinstall but it wouldn't even deinstall so, thinking it might be a corrupt file I have reinstalled. No change.

Do you have

(a) any ideas why it should take so long to start up - things I can change to improve things?
or
(b) an uninstall tool, over and above the Win7 deinstall routine which isn't working?

I've been a happy customer for quite a while and all I really want is for Opus to work properly again!

Thanks

Paul


#2

Have you tried killing the process, then doing the uninstall?

If you can uninstall & reinstall, see if things work OK like that before restoring any kind of config backup, in case the problem is related to the configuration.

Process Monitor can be useful as it will show you the files programs are accessing, which is likely to point in the direction of what is going on.


#3

Also, if you type coll:// into the location field, do you see lots of file collections you don't recognize? If you have lots of accumulated collections from searches it's possible these are slowing down the startup. They're safe to delete if you don't recognize them or want them.


#4

Okay, so I've managed to deinstall (don't ask me how, I lost track) and reinstall. The issue is that it takes ages to open on the first opening of the program. After that it's snappy and like it used to be. But first opening? Nope.

ProcMon doesn't throw anything untoward up.
I don't have any Collections

It's just that first opening.


#5

We have a built-in startup diagnostic which may help. Here's how to access its information:

[ul][li][ol][li]Set HKEY_CURRENT_USER\Software\GPSoftware\Directory Opus, StartupProgress (DWORD) = 1.

You can use the two .reg files in here to set/remove it, if you prefer:

Opus_StartupProgress_registry.zip

[/li]
[li]Run Microsoft DebugView

[/li]
[li]Launch Opus.[/li][/ol]

DebugView should print some lines with "dopus: Startup progress: 31" or similar.

(DebugView defaults to very narrow columns, so if everything is truncated they just need to be dragged wider.)

(DebugView may also print output from other programs. Not everything it displays will necessarily come from Opus.)[/li][/ul]

Usually all the "dopus: Startup progress: xyz" lines should all go past quickly, but from what you're seeing we might get a long delay between some of the lines.

Please try the steps above and post a screenshot of the log. Please make sure the columns are all wide enough so we can see the timestamps and progress numbers.


#6

Hi thanks for coming back so fast. I think the issue lies around line 52 onwards. Any ideas on what that all means?

Cheers



#7

Something weird just happened. When I opened an Opus Lister, the act of doing that switched off my Antivirus package (Bitdefender AV2015.


#8

Please go to:

C:\Users[b][/b]\AppData\Roaming\GPSoftware\Directory Opus\ConfigFiles

Then move smartfav.osf out of there and to your desktop or somewhere else for safekeeping.

Kill dopus.exe if it is still stuck (or fully exit Opus (via File / Exit Directory Opus) if it is running normally), then start it up again and see if it gets beyond "Startup progress: 37".

If that does solve things, open up the saved smartfav.osf and please paste what was in it here so we can take a look (assuming none of the paths inside are private).

I suspect that is a coincidence, unless triggered by a shell extension. It's not something Opus itself would do.


#9

Here's the content of that file. Nothing to report AFAICS

<?xml version="1.0" encoding="UTF-8"?> P:\!Video

#10

I restarted the computer, let it sort itself out and then double clicked on the Directory Opus icon at 14:08.
Dopus.exe and DopusRT.exe are both showing in TaskManager.

Opus opens a lister at: 14.22
I'm at a loss... It's getting even worse.


#11

With smartfav.osf removed, what does the debug output show now?