GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Starting Opus via a user command

I always want to start Opus with the same Tab group open in a single lister to achieve t his I have set the preferences to:

I have placed the following commands in a new user command called rogstart

Go TABGROUPLOAD=Tome
Set LISTERSIZE = 2800,1840
Set LISTERPOS = 100,10
Show THUMBNAILSIZE 320

At least 50 per cent of the time I start Opus the commands do not run.

Instead Opus opens with a top level view of of the USB drive used by Acronis to back up my system. I do not know whether this is significant, but if the rogstart user command does not run Opus always starts with this view.

In the scheme of things it is not the worst problem in the world, but it is irritating. Any ideas what I am doing wrong?

You would normally use the Default Lister to specify the window size and folder tabs that open when you open an Opus window. Or a layout, if you want the default lister to be something different.

If something launches Opus to ask it to open a folder, e.g. Acronis in this case, then Opus will not run the startup command; it will only open the window it was asked to open. The options there specify what should open if Opus is run in a way which doesn't already cause a window to open, and it avoids opening a second window when asked to open a window (since you'd usually not want that).

The Explorer Replacement page has options for what happens when another program asks Opus to open a folder. For example, you can specify that you want the folder to open in a new tab, in addition to any tabs in the Default Lister.

If the USB drive is opening and you don't want it to be opening at all, then you need to track down what is opening it and make it stop. You'll probably find that if you turn off Explorer Replacement it causes an Explorer window to open instead of an Opus window, with the issue being outside of Opus.

Thanks for your thoughts, Leo.

I went away from using the Default Lister because I could find no way of getting the Lister to the screen position and size I require.

What is interesting is that if I apply rogstart as the choice what opening Opus by double clicking the desktop or by clicking on the Opus icon in the taskbar, it works every time without fail.

If I try to use Win + E the rogstart script never runs.

The Acronis theory is just that - based on the premise that it is always the drive used for Acronis backups that opens when it all goes pear shape. It could be something else - I keep my regular Opus backups on the same drive, for instance.

I have instructed Opus to to open any folder a program wants to open in a new tab. I will see what happens now.

Settings > Set as Default Lister in the menus, to save the window size/position.

Launching Opus / Default Lister in Preferences to control where and on which monitor(s) it opens on.

Many Thanks