Strange customize problem

I have a very strange least I think it is. It's probably my bad....

Since the 8.2 update I cannot directly add predefined buttons to my menubars. I have to drag a command to the desktop and then drag the shortcut to the menubar to make it work. It only happens @home, on my work PC it works fine and it is the exact same configuration.

Any thoughts?


I've never heard of that happening before. I'd try a reinstall of Opus to see if it helps.

It could conceivably be an anti-virus (etc.) system getting in the way of drag & drop but I've not heard of that before so I doubt it.

This has popped up with one other user recently.

Do you run a Registry Cleaner? It turned out that the other user had run a registry cleaner recently, and it had removed an important registry key (the one defining the IStream interface which is used by Opus for COM operations like drag and drop).

He was able to solve the problem simply by copying the IStream key from another machine and rebooting.

I have uploaded to our website a registry file which will restore the IStream key on your machine. All you should have to do is double-click the .reg file and tell it to add the entries to your registry. Then reboot, and see if it solves the problem.

You can download this file from

Please report back how you get on with this!

Thnx for the quick replies!


This could very well be the problem. I'm currently @work (Damn timezones :slight_smile: ) so I'll check it tonight.

Thnx again,
I'll report back if it worked.

This is similar to the problem I'm having. I am unable to add any Toolbars to the system.

I have not run any registry cleaners.

But I will take a look at the file and see if it fixes the problem.

No joy.

I still can't create a new toolbar. I click on the new button. Name the toolbar. It shows up but I am unable to check it. Then the next time I try and define a toolbar the last one I created doesn't show in the list.

Running on Windows XP Pro.


Your problem with creating toolbars sounds like your account doesn't have permission to write to the directory where the toolbars are stored.

Which directory that is depends on whether you're using shared or per-user configuration in Opus. Shared configuration will put toolbars under Program Files, e.g.

C:\program files\GPSoftware\Directory Opus\Buttons

Per-user configuration will put toolbars under your profile directory, e.g.

C:\Documents and Settings[u][/u]\Application Data\GPSoftware\Directory Opus\Buttons

Go to those directories and see if you're able to create a new text file or similar. If you get an error then that's the problem.

Well it worked like a charm. Now the hunt for the "registry too well cleaner" begins. Haven't used one recently......ah well. It works :slight_smile:

thnx everybody

Good guess on the permissions. But it's not the case. I'm the only user and have all priviledges.

I can actually create the new button file, test.dop, in this case. But I can't edit it or activate it. And if I exit the customize menu and come back it doesn't show on the list of available buttons.

But you gave me an idea. And this is what happened. For some reason DOpus was looking in the shared directory when it should have been looking in the Per-User directory.

Cool. Don't know why it was looking in the wrong place but I'm glad it's sorted now.

If anyone else has the same problem and comes across this thread, you can change between per-user and shared configurations via Preferences, Miscellaneous, Miscellaneous where it says Change the configuration mode the next time Opus is run, below which it tells you the current mode.

I've been having a similar problem. I can no longer drag and drop new buttons onto the toolbars, but I can still right click on them and add a new blank button. Not a big deal I guess, but its still an oddity. I think the problems started right after I tried adding right/middle click functions to a couple buttons, and then deleted one of them completely.

Try the IStream thing described above and report back.