Strange: global search doesn't work anymore

If i search files, no results are returned anymore, only a bunch of empty collection folders. In the indexing options, everything looks ok, that shouldn't be the problem. Has anyone noticed this issue?

Here is the command, that used to work for years:

FIND IN "H:" "K:" "L:" "M:" "P:" "R:" QUERY {dlgstring|search everywhere}

Does the same query work in File Explorer?

Yes, i have just tested it.

Does the Windows Search field work in Opus with the same query?

(top-right of the default toolbars)

Can't find that. Both toolbars have the "help" question mark at the top right. Otherwise i can't find a searching icon.

I'm sure, you didn't mean the F3 quick search, which still works as intended.

Very hard to help when you're still using toolbars based on Opus 6 :slight_smile: Time to update to the current defaults.

I turned those toolbars on by right click, both "menues" & "operations". At the right i can find only the help icons.

I have also made a backup, to completely reset the toolbars to factory setting. Sorry, i don't see any Windows search. Is there a screen shot, so i would exactly know what to search for? Or any other way to trigger that search from within Opus?!Documents/The_Default_Toolbars.htm

That's not how the menu toolbar looks in the german version. No search field at the right, & i'm sure, i have never edited any of the default toolbars.

In the meantime i have checked the old search from the admin's account. It turned out, that the search is working there, although i remember, that the search results were shown alone in earlier versions, whereas now i see some empty search folders at the top of the list (which is not a problem, i just wanted to mention the change).

Edit: also other details from the manual's menu version don't match. Is it possible, that the german version is different regarding the layout?

Update, if i reset the toolbars to factory settings, there is indeed a search field, sorry. But it looks, as if it just works like the F3 search field. I have to be in the right folder, to find the item, but the global search still doesn't work.

So search works, but not the command in the root post.

Do all the drive letters in the command still exist, and are they all accessible from the account you are using?

Well, the search does not work, as i said. I expect to find G:\example01.rtf to be found, if i trigger the search from being in L:\ or any other place. What works, is the lokal search F3 style, which finds only items under the current location.

Yes, they all still exist, also in the indexing options, showing almost half a million items. All drives are accessible from here, as i can browse every drive without any problems.

I mean the standard toolbar search field, which always searches from the current folder and below, is working. That means Windows Search itself is working from Opus, and the problem will be to do with the command.

I don't know which search you're using where you'd expect to find something in G:\ when starting in L:, unless you mean the command at the top of the post.

What is the query you are feeding into the {dlgstring} prompt when things do not work with the command?

Yes, i mean the custom command. For example, i have tried as a query to find "*.mp3", which should bring up plenty of results. Or i try to search some other test file (for example on dribe G:) from a different location. But, as i said, it looks very suspicious, that the find results (none, in that case) come up almost instantly. I would expect the search to continue for a few seconds, as it used to be, before all drives were searched.

You probably want to use filename:*.mp3 and not *.mp3 since that might search content as well as names, with Windows Search.

You probably also put quotes around the query string, in case it contains spaces, e.g.

FIND IN "H:\" "K:\" "L:\" "M:\" "P:\" "R:\" QUERY "{dlgstring|search everywhere}"

If I do the following test, after a while of searching I start to get back lots of results:

FIND IN "C\" "D:\" QUERY "filename:*.mp3"

You should see a block moving across the address bar while the search is still happening. Do you see that at all?

I have made the change you have suggested, butting qotes around the old command, but nothing changed.

Yes, i see the block with the second command. But something really strange is going on with my machine. There are literally tens of thousands of MP3 files, but the search didn't find a single one of them. Instead it found only folders, containing the word "MP3".

Maybe i should run the indexer again?

Actually, not even Windows finds those MP3 files. Instead it offers me to search the web. :angry:
Maybe i have accidently turned off the ability to search the computer, because recently i've tried to remove that feature, to search the web, when i only want to search my local disks. I find that behavior unbearable, that's why i tried to get rid of that function.

Does the same query work in File Explorer?

Yes, i have just tested it.


Actually, not even Windows finds those MP3 files. Instead it offers me to search the web.

So the same query doesn't work in File Explorer?

First, i have tested to find some of the files on some drive, searching the whole name, like 1234.png, where Explorer returned results. Later i tried to find *.mp3, but no results. Now i have Windows rebuilding the whole index, but maybe still 80% of the files to go.

But it looks much better now. Even though the indexing is not through, Opus is finding stuff again. maybe the index database was corrupted for some reason? I will report back later, when all indexing is done. But yeah, looks promising. Thanks for your help, guys!

It's all back now. I have no idea, what happened, but the index must have been faulty.