GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Tab functions not working with tab groups?


#1

Hi guys,

Hope you're well. I recently discovered an issue in 12.10.0.

The tab functions:
Close Tabs To Right
Close Tabs To Left
Close All Other Tabs

are not working for me, when the tabs have been opened by a tab group. The functions work fine, if the tabs have been opened via a favorite or a the "open a new folder tab" command.

Thanks,
Kind Regards,
Marcus


#2

I can't reproduce this unfortunately. Please see this video, is there something I'm misunderstanding?


#3

Thanks for the video.

That's weird, I'm doing more or less the same things as you. I have no idea why this is working on your side but not for me.

I've uploaded a video, maybe it gives you some additional insights? I could also provide my setup, I don't know if it helps or not.

Here is the video:
"www.sidequest-studios.com/MarcusStuff/2018-11-07_08-58-55.mp4"

Thanks,
Kind regards,
Marcus


#4

I have the same symptoms here. With any tabs that opened as part of a tab-group (with the default lister in my case), none of the OP's commands work. Add a couple of tabs 'manually' and they do work but only on those manually opened tabs.

Update: I set one of my tabs ('Documents') to 'Unlocked' and tried again and if I right-clicked a locked tab and selected an option, only the 'unlocked' tab was actioned. I'm guessing that a 'locked' tab isn't affected by these menu commands.

2018-11-07%20(1)

Directory Opus Pro 12.10.1 (Beta) Build 6872 x64
OS 10.0 (B:17134 P:2 T:1) SP 0.0


#5

This is by design, if tabs are locked they aren't affected by those commands by default. You can hold the shift key down to override and force them to be closed.


#6

Thanks for the clarification. Was this adjusted in one of the last updates? I'm pretty sure this worked for locked tabs without holding shift in older versions. But pressing shift ist fine for me.

Thanks,
Kind regards,
Marcus


#7

No, this hasn't changed for a long time.