"The handle is invalid (6)" error

Hi, anybody else seeing this?

Vista Ultimate x64, DOpus 9 (upgraded from ver8), copying some driver files from HDD to floppy gives this error:-

An error occurred copying si3114r.sys:
The handle is invalid. (6)

Copying same files with Windows Explorer gives no problems.
Any fix? Thanks.

/me digs out a floppy disk...

Confirmed! I can reproduce this on Vista 32-bit. I've got a feeling about what may be causing it and I'll talk to GPSoft about getting it fixed.

(Wow, I forgot how small and slow floppies were. "I'll just copy this file here as a text... oh wait, that's bigger than would fit on the floppy even if it was empty." :slight_smile: )

I've found a workaround.

Go to Preferences - File Operations - Copying Files and set the Buffer Size at the bottom to 2048 KB. That's larger than any file that will fit on a floppy and it will ensure that files copied to the floppy will be written in one go, instead of in several chunks.

When files are copied to a floppy in a single write the problem seems to go away.

nudel, confirm yr fix works! Many thanks for the speedy response.

This has been fixed now. If you experienced the problem, please download the minor update. More details here:

[Directory Opus 9 now available!)

staveley, it's probably worth setting the Copy Buffer Size back to the default (64KB).

i don't know if anyone else is having this, but i'm experiencing the similar problem, but only if moving a file from source local drive to dest network drive. i tried changing the buffer as above, but that only seems to work for files smaller than the buffer (which for me caps at 9999)..

Have you tried again with the updated version of Opus 9?

there is... updated version? i'm using right now. do you have a link?

Yup, see the announcements forum for info. To get the update you just download the installer again from GPSoft.com.au.

yes! thank you!