The toolbars when saved just add another .dop to the end

When I save toolbars (the .dop files) it just adds the .dop to the end, so I end up with many files, ie:

and, of course, it never loads the correct one with my changes to it. If i try to save it as the first one (just 1 .dop on the end) it doesn't save it under that name. But it loads up the first one, so that I have to either redo the settings I want, or have to screw around with the extra .dops until I get the one i want, and then have to change their appearce order around because it's all screwed up (not the buttons on the toolbar, but the order of the toolbars).

What am I doing wrong?

How are you saving your toolbars? From the customize dialog box? If so, I cannot duplicate this behaviour. If you're saving them another way, please explain how you're doing it.

Also it might help if you post the version of Opus you're using.

okay, version U is what i'm using

It does it when I right click on a toolbar and click save.

I haven't figured out any other way to save them.

plus it's not like I'm making special toolbars for different occasions, I just trying to set up so it has all the tools and custom commands that I have made, where I can get to them.
I just use the dual vertical with no folder trees, no view plains.
With just the listermenu, toolbar, and pathbar
That my default.


You don't need to 'save' changes to a toolbar. Once you make the change and exit 'Customize' mode by hitting Ok, the changes to that toolbar are 'saved'. It sort of seems like you're trying too hard :slight_smile:.

Along a different thought - the concatenated .dop.dop.dop (etc) extensions on the toolbars you're 'saving' smacks of a side effect some people have reported after they've tried making changes to their toolbars. None of the beta testers have been able to reproduce this as far as I know... but if your issue is not JUST a matter of manually 'saving' toolbars when you don't really need to, could you take a look to see if you have any other symptoms in common with others seeing this behavior based on their comments in the following threads?

[url]Toolbar nightmare]
[url]Shared Config vs Personal Config]
[url]Strange customize problem]

Why don't people run the latest version???

At least update to the current release when you have issues - whilst your problem may not be something which was addressed in the update it's better to check at least.

Or is it that people can't update when their version is ... ahem ... dubious...

Hello nyder,

I'm sorry.
I tried to duplicate your result.
I had to restore an old C drive backup to get DOpus ANSI.
The ANSI version did not result in the appended .dop on my system.
I understand though that you are using the Unicode version of DOpus .

Wouldn't it be just as easy or easier to copy the actual toolbar to a safe place?
I use a Styles Tab to open a dual pane place with specific Lister Tabs to accomplish exactly this.
I Drag and Drop the dop file !

Hi Tanis,

In this case, I have no idea why not.
However, my more general ( idiomatic ) reply might be Type Clock$ .
Just a guess .

P.S. Tanis
Sit tight, I'm working on a reply to the previous thread we started discussing things on.

:opusicon: Porcupine

the reason why i was saving the toolbars is because it wasn't saving them when I exited the program, I think. Not really sure now if I was doing something wrong.

I think I had the setting loading up the default dual veritcal or something, and my stuff wasn't saved to that. But i changed that setting and it doesn't seem to be a problem now.

As for not using the latest version, wasn't it just released a little bit ago?
not that it matters, I do usually update stuff to the latest, I'm just not into stuff automatically updating, can cause too many problems (not that it would cause Opus any problems, but I like to be safe.)

I don't know why i'm using the unicode version, it's not like I have to. I can only read & write english and i'm pretty sure ansi has me covered in that front. =)

So, I guess, I will install the latest version.

oh, ya, I thought maybe the default toolbars were set to read only, but that wasn't the case, it just doesn't seem like it wants to save to them. But that doesn't matter now, since that isn't the way i'm supposed to do it.
Guess maybe I should rtfm, but, well, along with my dyslexia I'm AADD, so I have to reread everything a few times since my mind starts wandering... =)

not that i'm making excuses, it's just when I last pulled up the pdf, I noticed some weird behavior in Foxit (what I use to read pdf, great program!) and i got distracted dealing with it. It likes to open the manual to page 40. yet it doesn't do that to any other pdfs i have, and it's not like it goes to the last page you were at, because I kept putting it back to page 1 and still it would open to page 40. not that it has anything to do with this, just giving out excuses. :blush:

thanks for the feedback, I appreciate it.

There's no real reason not to use the Unicode version.

hey nyder...

Having things set to load dual vertical isn't related to 'toolbars' so much as layouts. So if you're still having a toolbar problem and haven't managed to read through the other threads mentioned above to see if you have something else in there in common, then try and hook us up with a specific step by step description of what you're doing to modify your toolbar that should automatically be getting saved, and what you've done just before noticing it hasn't apparently saved... i.e are your changes ok until you close an existing lister window, and then gone when you open a new lister... etc etc.