"There was a problem sending the command to the program

"There was a problem sending the command to the program."

Clicking on a shortcut to Listers, Recycle Bin, or Control Panel often gets this error message. (No other program gets it). It takes some time ("obvious pause") to give message. Upon retry the connection may work. Keep dblclicking until it works. After the first one is running generally don't get it again. Sometimes I have to reboot for it to work.

Have you seen this before and what actions can you suggest?

Dell Dimension 6400, 3.4gh P4, 1mb memory. 68gb free space across 4 logical volumes. Win XP Pro SP2.

Thank you, Dick Pape

All the things you're mentioning (not sure about shortcuts to Listers - you mean just the default Opus shortcut installed with the program?) appear to be a result of enabling Explorer replacement mode. You might want to try toggling it on and off... perhaps something in the registry related to this setting has gotten weirded out? Goto Settings->Preferences->Miscellaneous->Explorer Replacement tab and select the Don't replace Explorer option. Then make sure that that opening My Comuter, Control Panel, Recycle Bin etc etc works ok with Explorer. Other than that, the only thing I can think of is some problem with the parameters being passed... Dopus makes use of the same %L and %I parms for compatability with Explorer I guess, but I don't know what they actually represent or how you would confirm anythign with them are indeed a 'problem'. If Explorer works ok after the change above, set one of the options back to use Dopus in an Explorer replecment mode and see what happens and let us know?

I used to get this on my old Win98 machine with both Opus and TextPad when launched in certain ways, and I've seen official reports about it affecting TextPad in their changes log.

I believe what you're seeing is some program that is taking a long time to process a DDE request. (DDE is an old way for commands to be sent from one program to another and is still used by the Explorer shell to launch a few things.) Apparently only one DDE request can be outstanding at any one time (at least when the shell is sending out the requests) so nothing can happen until the blockage clears. I assume there's a timeout on each DDE command but that it can be quite large.

I never got to the bottom of which program was actually causing the blockage since it was around the time I moved to Windows XP and it stopped happening for me then. It may have had nothing to do with Opus and TextPad even though they were visible affected.

I think, after moving to XP on my work machine, I did see the problem again when launching TextPad but I solved that by editing the TextPad context menu to make it launch TextPad via the command-line instead of via DDE. I think newer versions of TextPad do this anyway.

If you do track down the problem, whether it's something blocking DDE or something else, let us know in case other people have the same issue.

Hmmm... interesting, I wonder if there is any utility to flush whatever DDE uses for a queue.

Also, Dick (er... Mr. Pape?) are you running Zone Alarm or CA/Etrust Firewall software? Or for that matter - any firewall software?

Hi folks. Thanks for the interest.

I wasn't ready to reply just yet as I couldn't get things to jell -- I was still working on my "feelings" about the problem.

Seemed when I turned off DOpus things cleared up -- no error ("for the most part!"-- justa a feeling). Turning it on for "...all but the following" I could get the error on Recycle Bin or Control Panel (two of the exceptions) as well as DOpus. Not every time, not all the time, but could keep dblclicking until it worked. Or got tired and rebooted -- which often solved it also.

Sounds like some sort of "taking a long time to process a DDE request" -- I don't know what that means but, I get an exceptional lengthy wait ("several moments" -- a pretty definite feeling) until the message comes up. Once I get one running, the msg doesn't come around nearly as often (more feelings incident reporting).

Another thing which may not mean anything: for the last couple of months, my system started using a lot more ram (I have cpu usage/ram meter always visible.) When I first got the computer it ran slightly under 500mb (out of 1000mb)and I worried it wasn't using all I had purchased. Now it's always greater than 500mb but less than 700mb -- and I'm not sure why -- I haven't changed my life style at all unfortunately. It might have coincided with DOpus installation. Right this minute DOpus is using 17,224k and Explorer is using 18,636k And neither is open directly.

Gee, you mean it's ok to run without a firewall? I have Zone Alarm and AVG.

Thanks, Mr. Dick

(I thought this was posted yesterday ... fortunately I had a copy of it, oh well).

The problem may well be triggered by having Opus set as the Explorer replacement. We've seen one or two things in the past which lookup the program set to handle Folders, assuming it will be Explorer, and send it DDE requests that Opus doesn't know how to handle.

So that is possible, although I'm not aware of issues with any current programs and I think there was a workaround added to Opus (presumably it tries to forward the DDE to Explorer or something).

Since you're runnign ZoneAlarm and that program can be the cause of so many problems, I would definitely try disabling ZA just to see if the issue goes away. You might as well try disabling the anti-virus software as well (it isn't unthinkable that a firewall or anti-virus program would try to intercept DDE messages). That is assuming you can normally reproduce the problem quickly and are able to do a quick test with them both disabled and then turn them back on without spending too much time defenseless.

If you can work out a combination of programs/settings which causes the problem then we're on the way to fixing it.

For consideration:


What, ZoneAlarm causing a problem???? I never would have believed it!!!

Wow Nudel and Steje !
What a cyberspace discussion !

The only thing I have to say here is, please be careful in your insightful analysis, not to put the cart in front of the horse !

:opusicon: porcupine


I don't think we've necessarily even hitched the cart to the horse leaders yet Porc. Lets' see if Mr. Dick has any results from looking into the Zone Alarm thing. I just found it awful coincidental that the same error (which I''ve never seen in Windows before BTW) has been tied to ZA interfering with Windows Exploder no less... And as Jon's bit of fun sarcasm affirms, it seems like people have been finding a fair number of Zone Alarm/Opus gotchas.

Pape... what say you dude? Are we adding another ZA/Opus gotcha to the list?

Whell, I tried Zone Alarm setting for Windows Explorer to no success. Not sure I did it right, so thought my next question should be "if not Zone Alarm, then what do I use? Since I'm using the free version, little lost if I change.


It's worth trying with ZA disable completely since you might need to make that setting on other programs as well.

I noticed some DDE (I think) issues on my machine at work which were preventing a lot of programs from launching, locking up the taskbar and sometimes locking up other programs.

In the end it turned out to be because I'd left a network drive mapped to a machine which was now switched off. Good old Windows then checks the drive every so often and half the OS, along with the programs which depend on it, seems to lock-up while it waits for a timeout... Which is nice.

Well, that was awfully considerate of Windows to go so far out of it's way to let you know that you had a bogus drive mapping...

was this ever resolved, as I get the message, and having just turned off the DOPUS explorer integration, which fixed it. I now turned on explorer integration and it still works fine!

However, I dont have ZoneAlarm, but I am on XP SP2, but I have its filewall turned off also (silly me!)

If it coems back now I've toggled the setting I'll let you know.

happily, having turned the DOPUS explorer integration settings back on, I now get the message "There was a problem sending the command to the program." again.

Oh, forgot to mention that I only seem to get the message when trying to use "Windows Desktop Search".

I have just managed to get it up IN a dopus window, and add it to my favourites as " - Windows Desktop Search". and it seems to work doing that!

I now have dopus set at "replace explorer for all but the following", and have left the defaults (ie I havent added in "Windows Desktop Search"

Nothing has changed for me. I get the message every so often (daily?). I try the action again and more than likely it succeeds on the second or third attempt.

It's a sloppy solution, but works.

I get it on Recycle Bin or simple Dopus Listers.