Unable to connect FTP

I have verified that my firewall software is not interfering. Unable to connect to an iPhone app. Application is Folder+. I am able to access it through my web browser on the same PC. I reviewed the Opus manual, and have followed all directives contained within. Attached is the FTP log, and also I have pasted it below. Thank you.

Opening Connection
220 hi, this is a simple ftp server
331 password required
230 logged in
215 Unix Type: L8
MLST Type*;Size*;Modify*;
211 End
200 MLST OPTS Type;Size;Modify;
200 ok
200 ok
Connection closed
Opening Connection
Cannot Connect to Site.
052716_T2000.txt (4.89 KB)

Please try the suggestions in the FTP FAQ.

I followed all recommendations in the FTP FAQ. No luck. These are what occurred.
Passive mode (PASV) setting in FTP Preferences.
I tried with this option active, and not active.

Firewall / Anti-Spyware software.
As per prior submission, I turned off Firewall and Anti-Virus software.

Proxy Servers
I chose all the available options. I know that the port is 21.

The FTP log in the Output Window
I selected the debug option.

Connection Type
I tried all of these options, but the port with the application is 21.

This did not apply.

Using Another Client
It is able to connect via Windows Explorer

Latest version of Opus
I did an update, since I purchased this a couple of days ago, it is current.

If you connect but the directory listing is empty
It will not connect, so this is N/A.

"WSASTARTUP not yet performed"
This does not apply.

It seems like the server is doing something a bit non-standard; we'll investigate and see if there's anything we can do to make it work.

I've worked out what's causing this and we'll have a fix for it in the next update.

In the mean time, you can work around it by creating an entry for the site in the FTP Address Book, and turning off the Use RESUME option on the Misc tab for the site entry.

The fix for this is now available in the 11.18.1 Beta version if you'd like to try it (unless you're using the Opus 12 beta, in which case the fix will be in the next Opus 12 beta which is still a few days away).