Unable to download/update 12.10 from USA

For the last week I have been getting popups that 12.10 is available for download. When I click download the button dims for a moment and then returns to normal with no further action.
Went to website and tried to download 12.10 and no luck, cannot find site

Results of tracert cdn.gpsoft.com.au -

C:\Users\mrau>tracert cdn.gpsoft.com.au
Unable to resolve target system name cdn.gpsoft.com.au.

That looks like a DNS issue.

What happens if you run ping gpsoft.com.au ? Does that also fail? (Note: No cdn. this time.)

I was able to ping the site but I could also find it via http but when I tried to download it could not find the cdn site. I solved the problem by using my VPN and connecting through the Sidney AU site and was able to download the file. Still does not resolve the normal way from USA

I know this thread is super old, but I just ran into the same thing. Could not download. Changed my DNS to google ( 8.8.8.8) and it worked right away. Seems like a DNS propogation hicup somewhere.