Unable to read NAS folders that Win Explorer can

I have a DELL PrecissionM6700 Win10 laptop on which I am running DOPUS 12.28. I am attempting to access my ASUSTOR NAS but when I try to open my NAS folders, I get the Incorrect function error.

I use the ASUSTOR EZconnect app to connect to my NAS, map, and mount folders, which I can open fine with windows explorer, but DOPUS refuses, with or without virus checker or firewall on or off.

I do not get a credential pop-up requester and password protected sharing is turned on. This behavior only appears on this machine, my desktop and Surface pro at work fine.

After connecting to the drive in File Explorer, does the same drive then work in Opus?

Can any other software, other than File Explorer, access the drive on the affected machine?

Can you think of any relevant differences between the two machines where things work and the one where things don't?

Do they have the same version of the Asustor EZconnect and other related software installed?

Are you running Opus elevated on one machine but not the other? (Elevation can mean a different set of mapped drives and/or credentials are used for network access.)

I use ASUSTOR EZconnect to connect to my NAS, It mounts the folders and Explorer reads them fine. The folders subsequently appear in DOPUS, but I get the 'Incorrect Function (1) error.

Photoshop and others have no problems

I can't think of any differences, all are o the same licensed version of DOPUS, other than that the home machine is on the same network as the NAS

All machines are running the same EZconnect

Neither machine are running on elevated permissions

Thank you for your help btw. I have used and evangelised DOPUS since my Amiga days :smiley:

Would it be possible to make a make a Process Monitor log of what happens when you access the drive using File Explorer, and then with Opus?

(Can do both in the same log file, one after the other. Just tell us the drive's path so we know what to look for.)

A Process Monitor log of what happens when Opus accesses the drive on one of the machines where it works could also be useful as a comparison, as that should reveal where the two machines deviate.

I have the same issue on my desktop. Was there ever a solution?

I don't think any information was received after my last reply. (We would usually update the thread if anything happened via private messages, in case it helps other people.)

If you have the same issue, please answer the questions I asked in my 1st reply, and maybe make a log of what happens (my 2nd reply).

Thanks Leo,
The mapped drive opens fine in Explorer.
It then gives the same error in dopus.
Logfile.zip (97.2 MB)
Please find the logfile attached.
All the best,

Which path should I look for in the log?

I had turned off SMB as my ASUSTORE had advised to turn it off because of security issues. When I reinstated the service, my access came back. This could be an area to investigate maybe.

1 Like

Hi Leo,
It was N: and M: that I tried.
/Media and /Music
All the best,

The issue is either with the NAS, or something filtering it (e.g. antivirus). It is failing when asked to list M:\* and N:\*.

File Explorer is working because it's using a different (undocumented) API to list the directory. Both APIs ultimately end up in a low-level QueryDirectory call, but get there via different routes.

(QueryDirectory is what Process Monitor logs, but not something applications are meant to call directly; instead, they call a higher level API which then calls QueryDirectory.)

What Opus is doing is explicitly correct (and works with every other device in the world), so it's the NAS which is at fault here. From Microsoft's documentation on FindFirstFile, which is the API we call:

As stated previously, you cannot use a trailing backslash (\) in the lpFileName input string for FindFirstFile, therefore it may not be obvious how to search root directories. If you want to see files or get the attributes of a root directory, the following options would apply:

  • To examine files in a root directory, you can use "C:\*" and step through the directory by using FindNextFile.
  • To get the attributes of a root directory, use the GetFileAttributes function.

We are using X:\* as documented. And indeed using X:\ would be against the rules, at least for this API. (Maybe not for the undocumented one File Explorer is using.)

You should be able to show this information to the NAS vendor and get them to fix their bug.

1 Like