Unable to set preferred sort order for folders in lister

Hi All,

In order to have the most important folders come to the top of a listing, I have added a series of zeros to the front of the folder name, the number of zeros indicating the priority of the folder.

So I might have folders such as 000 Folder 1; 000 Folder 59; 00 Folder 26; 00 Folder 5, 0 Folder 9 etc in a listing and, in the past, the listing has been prioritising 000 above 00 above 0 followed by the folders that do not have leading zeros.

All of a sudden, this seems to have changed and the sort order now appears to treat 000 as being the same as 00, being the same as 0.

I have found it frustrating as I am now having difficulty accessing the higher priority folders.

How can I reset my folder displays so that the number of leading zeros is taken into account in the order of the listing?

Does it look like this?

000 Folder 1
00 Folder 5
0 Folder 9
00 Folder 26
000 Folder 59
Folder without 0

Then Numeric order filename sorting in the Folder Options is probably turned on.

Turning it off would result in

0 Folder 9
00 Folder 26
00 Folder 5
000 Folder 1
000 Folder 59
Folder without 0

Not sure how you reversed that order without putting the last folder on top though.

Thanks very much for your prompt reply. You are correct. Previously the folders with the 000 prefix would appear in the list above (or before) those with the 00, which are above (or before) those with 0 prefix etc., but I have not been able to find a way of getting the display back to that. It still displays correctly in Windows Explorer, but I prefer using Directory Opus.

Any further suggestions would be much appreciated.

You have probably clicked by mistake on the column "Name". Click on it a few times until the desired result and it will work. :slight_smile:

It still displays correctly in Windows Explorer

Well, sorting numerals before spaces looks odd to me. Is there a name for this scheme?

No. It's simply the way I have kept my most important folders at the top of my displays. I have used this method for many, many years, both in Windows Explorer & Directory Opus. It's strange that it seems to have changed all of a sudden.

How do I get better help with this problem, because it is cause me difficulty and wasting time accessing my more important folders?

This is an important issue for me, the first in all the years that I have been using Directory Opus.

Is this what you want?

image

In case that's what you want, you need to go to Folder Options. In the default toolbars, it's found in the top toolbar inside a drop-down menu called Folder. Another way to get to Folder Options is to right-click on any column header, and click More.

image

In the Folder Options window, switch to the Display tab and check the box for Numeric order for filename sorting. If you do nothing else and click OK or Apply, this change will apply only to the currently displayed folder. Note the title bar of my window below indicates I am modifying folder options for a folder named "Sort Test".

To make this change apply to all folders (inside DOpus), you need to click the Save button. This will bring up a new dialog box. You need to click the Save format for all folders (make this the default) radio selection. The two checkboxes below are up to you. You should visit the manual page for the Folder Options dialog box here.

image

Thank you for your prompt & detailed reply DesertDwarf. Unfortunately that is not the listing order that I used to have in DirectoryOpus. It used to be the same as in Windows Explorer, which is still correct and is shown in the attached screenshot. Any help in getting it back to the correct listing order as in the past would be very much appreciated.

image

This is how it currently is in DOpus...

We've traced this to a change made in 12.21.3. In the next update we'll restore the original behaviour in this situation.

Wow!! That's really great. Thank you!