GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Unacceptable Performance

I am concerned about the performance of Directory Opus. It lags terribly, and in some instances, simply will not respond for upwards of 10 seconds, if at all. When it does not respond at all, sometime I see an error message about a thread. Simply starting the application takes nearly 6 seconds. When I change directories or drives, that takes several seconds as well. And most attempts to right-click on an item for a sub-menu takes 8-10 seconds, and sometimes it never responds at all.

I am running with 5 internal drives and 3 networks shares. I am not sure if this impacts performance, but I thought I would mention it. I should also add that standard Windows Explorer responds just fine on my system. I really like DO, but its performance is making it unusable.

  • What does the error message say?

    The details about which thread it is may point to the cause.


  • Does this happen in all display modes, or only some? e.g. Thumbnails mode but not Details mode?

  • If you are in Details mode, does it depend on which columns are visible?

  • Does it only happen in certain folders, or in places where certain types of files (e.g. video files) are present?

  • Have you installed any script add-ins? They can affect performance.


The type of issue you're seeing is generally caused by a conflict with a third-party shell extension that something has installed. These two guides can help track down the cause if that is the case: