Undo History not working with Desktop

It appears like the Undo History is not working with operations performed on the Desktop Namespace.

An example:

  1. Open the Undo History viewer so you can see what's going on.
  2. Open the Desktop in your Lister (ie "go desktop")
  3. Create a new file, eg Text Document, in this Lister.
  4. Delete the New File.
  5. Note how nothing gets added to the Undo History.

I have my Desktop targeted to a folder on a different drive, so I tried browsing directly to the folder (ie E:\Desktop) and tried the above experiment and it all worked fine. In fact the undo history appears to work fine in every case except the Desktop Namespace.

Is this something I have setup incorrectly in the config or is it a bug? I'm guessing it is a bug because I've seen the whole history get messed up and undoing the last action at times results in errors.

I am using Vista 64-Bit but I tried exactly the same experiment on my girlfriend's PC using Vista 32-Bit and was able to replicate the issue exactly.

The Desktop virtual folder is handled by Explorer. When you view Desktop Opus is just a container for an Explorer window.

If you want the full Opus functionality, go to /desktopdir instead.

Thanks for the info.

I have a button that I use to quick access the desktop, so I have modified it now to "go /desktopdir".

I should have realised it was a namespace issue, as the documentation says:

"Opus supports most System Namespaces and virtual file systems such as My Computer, Desktop, etc for Windows and those from third party developers. However, since these Namespaces provide their own “black box” handlers and functionality, Opus commands can only be guaranteed to work inside Opus. Many Opus commands unfortunately cannot operate on files in most virtual folders. Opus tries to emulate as many of those actions as possible but the APIs of many Namespaces simply do not allow all commands to be supported. Opus commands not available in a virtual folder appear ghosted."