Update check always times out

It occurred to me today that I had not seen a DO update in a while. I was on 20.17. I tried to check manually (help/check for program updates) but the update window just sat there, swirling the busy pointer. I had the settings set to check automatically, but clearly that has been failing.

I've just updated to 20.20, and tried the update check again. Similar (lack of) result except this time it eventually said "the connection timed out".

Now, I do use a personal firewall (Windows 10 Firewall Control from Sphinx) and a PiHole using unbound for recursive DNS. I disabled all of that though, even though I've already made sure DO can get out to the 'net, but it did not help. I'm sure that I'm not blocking DO.

I ran wireshark and saw a very brief flow (14 packets) of traffic to and from, which clearly coincided with each try of 'check for updates'. That ip address seems to belong to to UK2.net, a hosting company in the UK. So it would appear that DO is communicating OK at least that far, assuming that IP address is where it should be talking to ???

Any suggestions how to proceed trouble shooting would be appreciated.

I don't think that IP relates to any of our servers, unless Google are using it to host blog.dopus.com, which the update checker queries for the news feed.

(That is not what blog.dopus.com resolves to here, but they might have mirrors in other countries, perhaps. It's also possible your own setup is using it for DNS or something else.)

The news feed comes from https://blog.dopus.com

The update check itself comes from https://www.gpsoft.com.au

Make sure you can access both and aren't blocking either or them.

Hi Leo,

Thank you for that, I can access both those locations. I'm getting a bit suspicious of that IP address. Neither resolve to that address using nslookup here. I'm going to dig a bit... I'll start by disabling everything 'clever' so I'm just going straight out the the 'net, and rebooting for a fresh try.

I think there's something very odd going on here. It might not be anything to do with DO as such, but...

When I try the update check, I see a DNS request go out for nl.torguardaccessvpn.com, and a list of A records returned including the mentioned IP address. There is no DNS request captured by wireshark for any DO site when I try the update check.

After disabling all my clever stuff and rebooting (now simply using openDNS for DNS and no firewall) the exact same happens again.

I do use torguard vpn, but the client is not even loaded (I only use it occasionally when needed). Something seems to be going wrong... the DNS lookup and traffic is clearly associated with me checking for updates, but why??? Looks like I have some investigation to do.

Check you haven't configured something under Preferences / Internet / Proxy in Opus and forgotten about it.

If that page is all turned off, then it's probably something to ask the torguard vpn developers about.

That was it... well spotted!

I would swear on a stack of bibles that I've no memory of doing that myself. I've no reason to, and wouldn't even know what to put in there. Oh well.

Thank you for your invaluable help, as usual.


1 Like