Update from 12.15 to 12.16 aborts and can not be install

During the update from 12:15 to 12:16, the update aborts with the message Unhandled Exception Error Number 0x8000FFFF Description:> Kernel \ ServiceProvider.cpp (121) and can not be installed since then. A broken installation file is eliminated because it worked on a second system.
The relevant tips such as deleting the InstallShiel folder, granting the appropriate administrator approving, deleting the Temp folder and the GP folder and resetting the Explorer Settings, I have already tried unfortunately without success. Has anyone else an idea where the problem comes from. Oh yes, the security tools have already been completely deactivated. Setting up another user account on the machine is unfortunately not an option, since it is likely to cause other problems.

That is the fix that has worked for everyone else who has this problem.

It won't cause any problems because you can switch back to your main account afterwards.

Hallo Leo.

Thank you for your prompt reply. Unfortunately, the variant with the temporary additional user does not work for me either. It comes in both the additional user account, as well as in the main account of the kernel / service provider errors.
Version ist Windows 10 - 64Bit (Build 1903).

That's the only fix we know of*, but it has worked for literally everyone else who has run into the problem and tried it (~15 people).

(*Other than reinstalling Windows, which a couple of people did before this fix was found, and also solved the problem for them. That's a lot more hassle, of course.)

Was the account you created one with admin rights? Do you get the exact same error message?

Make sure you have logged out of your main account while doing things in the other account, so that none of the files are locked by the main account when the second account tries to replace them.

Hi, 1.) the second account has also received admin rights. There is exactly the same error message. The installer's build bar went through about 80 percent, then the error comes. 2.) The main account is logged out. 3.) I have now found another working solution. Since I have a second computer with a second Directory Opus installation, which, interestingly enough, despite the same Windows version on 12:16 has been updated, I copied the GP folder from there to the appropriate position of the first computer. And lo and behold after a reboot of the computer funktiniert here the version 12.16, I then only have to enter the serial number and everything was fine again. I'm curious what happened at update to 12:17. Greetings and thanks Frank

It's not the update. Something has gone wrong on your machine. Everyone who has had the same problem has also found that older installers which used to work fine on their machines now have the same problem.

That's the same, no matter which version of Directory Opus I also take the mistake always comes. I wanted to say I'm curious what happens when updating to version 12.17 or later. The interesting thing about the whole thing is that it worked on me on the second computer, and it has the same software only other hardware.

It's exactly the same at my place. Error on my desktop computer and no problem at all on the laptop, both with windows 10..

Have you tried installing via a fresh Windows account?

I'm not a computer geek. Can you explain me step by step how to do that?

Thanx in advance.

There are a few ways to do it, but here is the one Microsoft recommend for Windows 10:

I did it this way and indeed it worked!

I'm very curious for the behavior of the 12.17 installer.

Thank you very much.

1 Like

You could try running the 12.16 installer from your main account (i.e. install 12.16 over the top of itself). Results should be the same as what the 12.17 installer will do.

(The issue isn't tied to any version of the installer. One or two people first saw it happen several months ago, and each time we release an update a few more people see the same problem when they try to install it, or any previous version, due to an unknown change on their systems. A lot of affected people seem to have CCleaner on their systems, but that may be a coincidence; a lot of people have it installed in general.)

I don't have CCleaner installed.

1 Like

Thanks! That rules that out.