Updating from 12.12 to 12.15 reverts to 12.12 after a reboot

I have 3 DO licences, 2 on boxes running Zonealarm (with the antiransomware thing introduced recently) and 1 on a vanilla Win 10 box.

I've updated all 3 from 12.12 to 12.15, but on ONE of the boxes with Zonealarm, DO reverts to 12.12 after the update and a reboot.

Any idea why? On all 3 the update appears to install correctly, there is no notification to need a reboot.
The version number referred to is in the Help > About box.

Have you tried installing with zonealarm removed?

Not yet. As mentioned, it worked on one machine, not on another.
Removing ZA is the next step.

Removing ZA should always be the first step :wink:

I removed ZA, rebooted, updated DO, rebooted.. It's still stuck on 12.12. What should I try now?

First, backup your existing configuration using Settings > Backup & Restore.

With the backup stored somewhere safe, uninstall Opus completely and then reboot.

Make sure nothing is left under
C:\Program Files\GPSoftware.

Then try running the installer again, and once it is installed restore the config backup via the Settings > Backup & Restore.

Just before I do this, I've noticed that the About box says 12.12, but "Programs and Features" says 12.15.
The dates listed are different as well.

Edit: removed DO completely, rebooted several times, DO stays on 12.15 now. Win!

1 Like