GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Upgrade Notification Continues After Upgrade

Environment

Windows 10, Upgrading from 12.11 to 12.12

Steps

  1. Receive the "Directory Opus News and Updates" in-app upgrade notification
  2. Click "Install" to install the upgrade
  3. Authenticate as administrator when asked
  4. When asked to reboot click "reboot later"
  5. Wait a few seconds

Result

The upgrade notification appears again. Directory Opus seems unaware that it is already upgraded but is just waiting on a reboot.

What happens if you reboot?

Thank you for your quick response! If I reboot it works as expected. I don't want to reboot, though. If I was willing to reboot now then I would have clicked "now" instead of "later."

You need to reboot for the update to complete. It's better to wait until you can before installing it.

(We have plans to reduce the times when reboots are required, but that's how the installer works now.)

I've had the same thing. It's not helpful; when I said I would reboot later, I wasn't joking and I do not need Opus nagging me every 15 minutes. I will reboot when it's convenient.

Secondly, at the end of the session I shut the machine down. When I powered back up again the following day, Opus began nagging me to 'reboot in order to complete the install' again. I checked, and the version of Opus that was running was indeed the previous one, not the one I'd installed the night before. Apparently it doesn't recognise a power-down/up as being the same thing as a reboot! A reboot at this point fixed the issue, but you clearly have a bug there.

Finally, following the installation of a new version of Opus, on first startup it opens the 'what's new' page. This was bad enough when it opened it in the Opus help-viewer window - it now starts my web-browser to display an HTML page! Please get this stopped - if I really want to know what's new, I will go looking for it myself. I do not want my browser starting. Oh, and it also doesn't work - the page that is displayed is completely blank.

Replacement of in-use files (which is what happens on reboot) is something that Windows does. I'm surprised it doesn't do it after a power-off but it's nothing we have direct control of - we just give Windows a list of files to copy on reboot and it does the rest.

You can disable the release notes through Preferences if you don't want them to come up after installing a new version.

I very frequently choose reboot later and immediately shutdown. As far as I know a restart sometime later has never failed to complete the upgrade.

In the next update we'll make some changes to reduce the frequency of the "reboot reminder".

A Fast Boot is probably enabled, so Windows does a hibernation behind-the-scenes and not a legit cold start (Windows updates will override this for themselves, but it seems Microsoft didn't override for third party installers which require reboot).

I would hope Windows still does the replace-on-reboot functionality even when doing a Fast Boot, or a huge number of things would be broken all the time and by default.

(That said, Fast Boot in Windows is still a bug farm and something everyone should turn off anyway. It just isn't worth the problems it causes to save a couple of seconds when you reboot.)

1 Like

I am having this problem too. I've turned off fast reboot on Windows 10 Pro, still getting message after a reboot. Though the message says to update to version 12.13, is that even out yet?2019-01-30_14-50-07

Correct, 12.13 isn't out yet. The website the update checker talks to briefly indicated that version, and it must have been cached. Apologies for that!

Please try this to fix things:

  • Fully exiting Opus (via File / Exit Directory Opus)

  • Edit C:\ProgramData\GPSoftware\Directory Opus\Global Data\globaldata.omd in a text editor (e.g. Notepad).

  • Find the place on the line which says update_new_low="xyz" update_new_high="xyz" and zero out the numbers: update_new_low="0" update_new_high="0"

  • Do the same where it says update_download_low="xyz" update_download_high="xyz", changing both numbers to 0.

  • Save the change and launch Opus again.

Does that fix things?

(If you have problems, please avoid posting the full content of globaldata.omd to the forum, since it contains your reg code.)

Works! Now shows 12.12 as current version. Thanks for your help!

1 Like