GP SoftwareTwitter
Opus FAQsManualCommandsObjects

"Use Filter" for Recycle isn't working


#1

I'm having a problem trying to compare / synchronize my local D dirve with my NAS Drive.
The specific issue is trying to filter the #recycle directory on the NAS.
I have tried a created a FIlter with various entries: (not at the same time)

  1. nomatch #recycle
  2. nomatch *recycle
  3. nomatch *#recycle*

My guess the # character is the culprit but I can't find the right combination. Any suggestions?

BTW:
My panel settings are: (those listed are checked)
two way copy
ignore seconds...
Use filter ...
Hide unaffected files

Many Thanks

John


#2

is a wildcard character (see the appendix near the back for the manual for a full list of them & their meanings). When using wildcards, if you want to match a literal # you have to put a ' (single quote) before it to escape it.

Here's the filter to use when synchronizing if you want to ignore everything in and below a folder called #recycle:


(Aside: When using filters for Find and other tasks (but not Synchornize), you can do this a bit better using a single Subfolder clause in the filter. More about that here.)