User command button not working in network shares

Hello all, I have a particular program I like to use to delete large directories when I don't need them. I created a command button for it, and it works in directories that live on local drives but not the network shares:

"D:\Tools\byenow-0.6\64-bit\byenow.exe"{sourcepath$} --yes

Here is the error I get:

Error: GetFileAttributes() failed with 123. The filename, directory name, or volume label syntax is incorrect.
Path: [\\xxx.xxx.xxx.xxx\SyncFolder\keep\this is a test folder" --yes]

[process exited with code 65 (0x00000041)]

I realize it's straightforward, but I'd appreciate insights into why it's not working on network shares. It works fine if I run it from the terminal.

You should have a space between the program path and the argument(s):

"D:\Tools\byenow-0.6\64-bit\byenow.exe" {sourcepath$} --yes

Thanks Leo. I added the space and still get the same error.

Here's the output if I run the command from the commandline.

D:\Tools\byenow-0.6\64-bit>byenow.exe "\\192.168.86.248\SyncFolder\keep\this is a test folder" --yes
Deleting [\\xxx.xxx.xxx.xxx\SyncFolder\keep\this is a test folder]

              Folders       Files      Errors
  Found           338        5504           0
  Deleted         338        5504           0

Completed in 00:00:27.801

D:\Tools\byenow-0.6\64-bit>

Try changing {sourcepath$} to {sourcepath$|noterm} in case the program has problems with slashes at the end of quoted paths.

1 Like

That fixed it. Thanks!

1 Like