GP SoftwareTwitter
Opus FAQsManualCommandsObjects

V11.8 - Slow Search Problem


#4

I tried deleting the two search results folders and then tried doing a new search - same result.


#5

Also - Just for an FYI - I have a 512GB SSD on the laptop (16GB RAM) and that's it. It is about 201GB used - ~279,000 files (Windows, Program Files, User data - everything) - User Data is about 130,000 files total.


#6

Thanks. That should rule out any issues with collections.

Let's focus on the Find panel for now, and ignore the Search field, since doing so keeps things more simple.

What exactly happens with the Find panel? Do you get the delay as soon as you open it, as soon as you type * into it, or when you click Find, or something else?

Does the problem happen even if you search inside a test folder that just has a couple of files in it? Does it happen with all folders, or just a particular one?

How is the Find panel set up? (A screenshot of it is probably the quickest way for us to see that.)

Thanks!


#7

Sorry delayed reply

  1. Problem starts as soon as I click on find. Typing in criteria is no problem

  2. Large directory or empty directory - behavior is the same

  3. Standard out of the box find panel set up (screenshot attached)



#8

Sorry - I mistyped on that last reply.
If the directory is EMPTY - don't see the problem.
With 5 files in it ... see the same problem.


#9

If 2 - 3 files (all Excel) - I can get the find results in about 5 seconds.
If 7+ files took 30 seconds to return a result


#10

Is it only when searching a library folder?

Or perhaps only when XLS files are in the results list?

Does the library point to any network drives or drives which have spun down or otherwise take a long time to access?


#11
  1. Library files - Most files on my machine are LIBRARY files But in fact the test directory was on the desktop - so I've seen the same problem both with library files and not.
  2. No any type of file ... I just used XLS as an example.
  3. Network drives - no I removed all network and virtual drives from my machine after the earlier problem I had with general response time

#12

Thanks for trying those things. That rules out some of the possible causes.

Some other things to try:

[ul][li]If you delete all the collections again, and then create a new, empty collection (when in the Collections folder, click the New Folder button), do you get a delay when going into that empty collection?

If not, what if you manually drag a .txt file into the collection, then fully exit Opus (via File / Exit Directory Opus) and then re-launch Opus and go tot he collection? Does the .txt file show up in the collection without delay?

[/li]
[li]Do you have any scripts installed? (Preferences / Toolbars / Scripts.) If so, try disabling them.

[/li]
[li]To test if the problem is related to your configuration or toolbars, backup your current configuration (Settings > Backup & Restore), then completely uninstall Opus, reboot, and reinstall it. You'll now be using the default settings and toolbars. Does the problem still happen? (After testing, you can restore the config backup via the same menu, but be sure to do the test before restoring anything.)

[/li]
[li]If none of those things make a difference, it would seem to be something external to Opus. That could include antivirus causing a small operation that should be fast to be very slow (e.g. blocking Opus from reading the collection XML data while it takes a long time to scan it or similar), or 3rd party shell extensions (ShellExView can list them) or even things like video codecs (Icaros, which is included in some codec packs, has caused some strange problems recently). Those are all things which get loaded into the Opus process outside of our control, and can cause almost anything if not well behaved.[/li][/ul]


#13

OK ... Let me try these things. Certainly I noticed when I created an empty collection and moved a text file in there it took about 5 - 6 seconds to show up. I'll try the other stuff.

I'll try deactivating anti-virus and see if the condition persists. I have no scripts at all. I will do a reinstall - however the only changes I have made in this installation are colors and backgrounds. I have no 3rd party shell extensions nor additional video codecs


#14

You'll definitely have some shell extensions, maybe without realising. Lots of tools install them for various reasons ranging from adding items to right click context menus to showing icon overlays for cloud storage state.


#15

Hi Leo -
Sorry for delay in response. I'm traveling on business through Asia and it has been hard to take time to troubleshoot this.

  1. Yes you are quite correct about shell extensions. I have a bunch. The utility you linked worked great.
  2. I am however at my wit's end about this. I have removed the last three programs I installed before I noticed the slow down, I removed AVG completely (problem still occurs even with no AV), I replaced it with Panda. I have used CCleaner constantly to make sure the registry is cleared up, I have completely removed DOPUS several times (I am now running 11.10) ... and still no success.
  3. I have not noticed any shell extensions that I have not already been using since I bought and configured this laptop originally though.

Short of wiping my out my laptop and reinstalling everything from scratch is there anything else you can suggest? Or any specific applications that have known problems with DOPUS? I have attached the shell extension list report if that is of any help.
Shell Extensions List.txt (91.1 KB)


#16

I suggest disabling all shell extensions and then rebooting. If it makes no difference, you can enable them all again and we know it wasn't any of them.

If it does make a difference, enable some and repeat until it is narrowed down to a particular extension or group of extensions.

Extensions related to cloud storage or version/source control would be my initial focus, as they are often tied to strange delays because they're trying to contact the network during operations which are expected to be instant.


#17

OK Thanks Leo. It will take some time but I will start working on that.


#18

Hi Leo -

After lengthy troubleshooting it turns out it was indeed a Cloud Storage software called PowerFolder. As soon as I uninstalled it, DOPUS resumed its normal snappy performance on searches.

  1. These two software packages had co-existed for sometime before starting to have a problem - so I'm not sure what set it off
  2. Have you heard of PowerFolder? Do you know if there is any way for me to use this without having DOPUS issues? It is a fairly important application for me.

#19

Was PowerFolder updated around the time the problem started happening? Or could there be something like your PowerFolder configuration includes a server which is now offline or renamed, so it's trying to contact something which isn't there?

Something like that could explain why the problem started, which might help understand the underlying cause, or steps we or the PowerFolder team could try to reproduce the problem.


#20

I'll work on that and check this week Leo - I am not aware of an update but it may have done it automatically. I'll look into it.

Thank you


#21

I was just going to start a new thread with the extremely slow and/or crashing Dopus search that I am experiencing recently, both from the Windows Search box in Dopus and from the Dopus internal search function.

Then I found this thread and stumbled upon "PowerFolder" -- which I also have installed only recently.

So probably, the Dopus search slowdown problems are caused by PowerFolder. The only thing I could say about PowerFolder at the moment is that it seems to add its own Icon overlay to the folders that are synchronized using PowerFolder.

I don't know however whether this Icon overlay would harm the dopus search functions.

Anyway, I hope we can find the reasons why PowerFolder interferes so much with those search functions.

Regards
David.P

Dopus version 11.6 64 bit on Windows 7


#22

Try disabling PowerFolder's icon-related shell extensions using ShellExView.

If that stops the crashing, you'll need to report the problem to PowerFolder's authors, as we cannot do anything about crashes inside of other shell extensions, other than try to blacklist the shell extension (which has the same effect as disabling it).


#23

OK thanks. I'll report back. Btw., uninstalling PowerFolder instantly restored Dopus search speed (and gave me a blue screen crash).