GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Version Opus loading and responding slow


I am experiencing EXTREMELY long load times for DO to open when my computer starts up. I have DO in my startup files. I am running XP Pro SP3. The DO icon appears in my task bar in a reasonable amount during the boot sequence bu the default lister does not appear for 3-4 minutes!. While waiting for the lister to open my computer is virtually locked up and unresponsive. Once finally open, DO is very slow to open selected folders.

I just installed the latest version and that has not helped.

I recently installed MS Office 2010. I don't know if that could be related to the slow DO load and response time or not.

I would appreciate some suggestions to correct this problem.


Is it just Opus that is slow while your computer is starting up, or everything?

If you stop Opus from starting up and try to open an Explorer window and navigate around a few folders, does it take a long time as well?


Opus has the most pronounced problem; 3-4 minutes to open and sometimes a minute or more to open a folder. Outlook 2010 has also been on the slow side, but nothing like the problem I have w/ Opus. I just uninstalled Windows Search 4.0, suspecting that may be the culprit but it did not seem to help. I have also tried turning off Windows indexing for each of my drives but that seemed to make things worse so I re-enabled the service on all drives.

I have been suspicious that something is keeping one or more of my drives occupied because I can hear almost constant disk activity and I see the activity light on much of the time. I have completed scans of my system with Registry Mechanic and Malwarebytes today and have also inspected services.msc for suspicious processes.


Try another file manager (e.g. Explorer), and use it to look at each of your drives just after booting to check they do all respond in a reasonable time. If one doesn't then that drive (and what might be accessing it) is probably worth investigating (e.g. using the Microsoft/Sysinternals Process Monitor tool set to run at reboot).


Explorer is able to open directories on all drives quickly. Curiously, after I opened Explorer, Opus also resumed normal operation and was able to quickly navigate drives and folders. I was suspicious that the problem would not be fixed that easily so I rebooted my computer. After the reboot, Opus once again is slow as molasses. Explorer operates normally.

I have a folder with many subfolders containing a large collection of digital photos. I clicked the + icon of the parent folder tree before I opened the web page for this reply and Opus STILL has not managed to expand the folder tree. My cursor turns to an hour-glass when I move it to the folder pane. If I click on the parent folder, Opus is able to show the sub folders in the lister window but the folder tree still does not expand to show the subdirectories and I still see an hourglass when the cursor is in the folder pane.

Ok, the folder finally expanded in the folder window - it took about 4 minutes to accomplish that task. Opus is once again operating normally. So it appears something slows Opus down for an extended period of time when my computer first boots or wakes from hibernation. After a while it appears to operate normally. Explorer is not exhibiting the same symptoms.


[ul][li]Have you got a real-time anti-virus scanner? Tried disabling it?

Depending on which columns you have disabled, Opus tends to open and inspect files more than Explorer, which may be triggering your anti-virus scanner to inspect all those files (and it may have a long queue of files to inspect due to just booting). Just an idea, though.

(FWIW, I use anti-virus without this problem but some it may depend on the A/V program and/or settings and/or Opus setup. Or it could be something entirely unrelated.)

[li]Checked for any drives mapped to network devices that are unreachable?

[li]Tried turning off all Opus columns (other than Name and Size) and viewer plugins (especially the Movie plugin)?

[li]Here's a list of other things to try:

General slowdown or instability investigation steps

I just added an extra suggestion near the top of that list, which is to clear Opus's File Collections (in case checking their contents in the background during startup is contributing to the slowdown; although it's done on a low-priority background thread and wouldn't normally be noticeable).[/li][/ul]