Very slow FTP

Any help would be appreciated here..

In FileZilla, a ~200Mb file takes around 5-10 seconds to transfer from the server to my local PC. There are no fancy settings - I just put in my username, password and the server address.

In DO, the same transfer takes ~18-20 minutes. I have tried FTP and sFTP over SSH - neither gives me any additional speed. I have increased the FTP buffer but it has made no difference. Passive mode makes no difference either. Is this just a bug of DO or is there something else wrong here? I desperately need this working!

Which protocol is FileZilla using? It only makes sense to compare transfers using the same protocol (and it supports at least one, SCP, which Opus doesn't).

Are the two programs using the same settings?

Is there firewall / antivirus software which may be treating each program differently?

Are there any useful messages in the Opus FTP log? (Detail on how to open the log, and how to put it into Debug mode can be found here.)

I think FileZilla is using multiple connections to the server (if allowed from the server from the same IP), downloads these parts and finally makes one file on your computer.

The server itself limits the download speed for one connection. But with multiple connections you can "increase" the download speed.

Google for "filezilla ftp multiple connections"

There are a lot of other download managers: (free as far as I know)

DO doesn't support this as far as I know. For small files (like program source code) it isn't required.

btw: When you try too much connections to one server from the same IP it could happen that the server closes your FTP account automatically without any warning (happend to me)! It all depends on the server settings.

In detail:

The download manager asks for the file size, e.g. 200 MB, splits it into the number of defined connections, e.g. 5, so 5 connections will be opened and connection #1 asks for the bytes 0 - 40 MB, the #2 for 40MB+1 byte until 80 MB, and so on.

E.g. broken downloads can resume with the FTP because they know the number of bytes downloaded and start at this point - instead of the beginning.

I myself just finally figured out after many years that my brutally slow connections to ftp/sftp's were due to DOPUS. There is also another thread on the subject here: SFTP too slow
For me if I use DOPUS I get download speeds maxing out at 150KB/s, if I use WinSCP I can get 3MB/s from the same server both using the sftp protocol. I almost feel like a fool for not realizing this years ago, but I always blamed my old web host.

And I just found the same limit with the latest version 12.

Would someone from GP Soft care to comment on why this has not been corrected in six years.

We don't see the same thing. I just did a test and got 500 KB/s downloading from a site whether I was using Opus or FileZilla. (That seems to be the site's limit, which is half my ISP's max speed, but well over 150 KB/s.)

If you are downloading multiple files in parallel using multiple FTP connections, that may explain speed differences if software reports an aggregate speed.

I am downloading (or uploading) one file at a time and still get terrible results. I have one file of 40MB that I frequently upload. I have tried this a number of time with directory opus and it always took at least 5 minutes, and the last time was over 40 minutes. I aborted that, switched to another ftp program, and it always takes less than 45 seconds. Everything else is identical.

So in my experience directory opus ftp is useless for anything other than tiny files. Something I really think you should investigate.

We can't reproduce that.

A lot of other things could potentially be involved, including antivirus, firewall, etc. (which may treat different programs differently) as well as the network and server involved. Some of those things are impossible for us to try, but if you can send us details of how to log in to a test server we can try that.

Slow FTP here as well. Noticed it when running some up-and download tests prior to an internet provider switch.
Internet connection according to internet provider: 100 Mb/s up- and download.
According to independent recent speedtests: 95 Mb/s up- and download.

(Single) test file: 1GB large copied to and from my website or rather domain.

Directory Opus download: 10 MB/s (about 80 Mb/s).
Directory Opus upload: 1.2 MB/s (about 9.6 Mb/s)

After installing FileZilla:
FileZilla download: 11.3 MB/s (about 90 Mb/s)
FileZilla upload: 11.3 MB/s (about 90 Mb/s)

Both programs at default settings; only entered FTP login info and go.

In the past had SmartFTP. Didn't use it anymore because Dopus supported FTP.
SmartFTP is nowadays expensive. Tried to install my old copy but with no success.
Guess I keep using FileZilla along with Dopus and use Dopus only for the small FTP tasks.

Hmm, so Dopus does have a weak link afterall ;-/
Oh: tested on Windows 10 64b; no third party virusscanners or firewalls installed. Active firewalls: native Windows 10 and router set as DHCP server.


1 Like

I've gotten a Macbook a while back and just noticed the other day that my Mac is way faster on the same FTP than DOpus is.

Which lead me to try out Filezilla on Windows. I was flabbergasted how much faster it was in comparison to DOpus.

I too would like to see this solved.

1 Like

For anyone using Directory Opus on Mac with Parallels: You need to set the optimization setting of Parallels to NO LIMIT and NOT to 4 out of 5. Otherwise, internet speed, INCLUDING DOPus ftp speed, will be extremely limited DESPITE 4 out of 5 setting. This issue has been reported to Parallels by me, but it has been present for some time and is tied also to CPU and Hard Drive optimization which means a fix might take a long time if it ever arrives.